В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
milka292
milka292
30.12.2021 11:38 •  Информатика

ПИТОН Чтобы как-нибудь скоротать время до утра, Нильс набрал на берегу полную пригоршню плоских камешков, залез на корягу, валявшуюся у самой воды, и стал бросать камешки в море. Да не просто бросать, а так, чтобы они мячиком прыгали по лунной дорожке.

— Три… пять… семь… десять,— считал Нильс каждый удар камешка о воду.— Хорошо бы до самой луны добросить!

Ну, до Луны далеко, а вот камни сосчитать можно попробовать.

Напишите программу, которая выведет все числа, соответствующие отскокам камня от воды.

Формат ввода
Вводится число n, не большее 9, потом проверочное слово.

Затем вводятся строки, пока не будет введена строка ЛУНА. Эта строка служит признаком окончания ввода, в рассмотрении не участвует.

Формат вывода
Начало и конец диапазона для вывода чисел определяются так.

Среди введенных строк рассматриваются только те, у которых в числе, выражающем длину строки, нет цифры n. А среди них найти с наибольшей и наименьшей длиной.

Если в строке встретилось проверочное слово, то ввод нужно прекратить и перейти к выводу.

Вывести нужно все числа от длины большей строки до длины меньшей (включительно) с шагом, равным числу.

Пример 1
Ввод Вывод
3
море
Хорошо бы до самой луны добросить!
Тихонько вздохнув, Нильс выбрался из пещеры.
Ветер улёгся.
Небо очистилось от туч, и большая круглая луна стояла над самым входом в пещеру.
До утра было ещё далеко.
Чуть только он обогнул выступ скалы, как перед ним открылось море.
Оно лежало такое спокойное, точно бури никогда и не бывало.
ЛУНА
80 77 74 71 68 65 62 59 56 53 50 47 44 41 38 35 32 29 26
Пример 2
Ввод Вывод
3
гус
И вдруг Нильс вспомнил: монетка!
Ведь у него есть воронья монетка!
Это будет получше самого плоского камня.
Нильс растянулся на земле.
А монетка покатилась по отлогому берегу.
ЛУНА
40 37 34 31 28

Показать ответ
Ответ:
IKristin
IKristin
21.08.2021 04:21
Во-первых, не whill, а while.
 Во-вторых, цикл с предусловием(while) выполняется только тогда, когда его условие возвращает ложь. Если условие возвращает правду, цикл завершается. Бывает так, что при попытке первой итерации цикла условие уже возвращает правду. В этом случае цикл не будет выполнен ни разу.
 Цикл с предусловием(repeat), наоборот, выполняется, пока условие возвращает правду и завершается ложью. Стоит заметить, что если цикл с предусловием проверяет своё условие перед итерацией, цикл с постусловием делает это после, а это значит, что последний выполнится хотя бы один раз.
0,0(0 оценок)
Ответ:
MrWolf1244
MrWolf1244
21.04.2022 17:14
На Java:

class SearchPalin{
 public static void main(String args[]){
  String palinString = new java.util.Scanner(System.in).nextLine();
  System.out.print("\nПалиндром(-ы):\n  ");
  for(int wordStart = 0, wordEnd = 0; wordEnd<palinString.length(); wordEnd++)
   if(wordEnd+1==palinString.length() || palinString.charAt(wordEnd+1)==' '){
 String wordBeginning = "", wordEnding = "";
 for(int wordBe = wordStart;wordBe<wordEnd+1;wordBe++)wordBeginning+=palinString.charAt(wordBe);
 for(int wordEn = wordEnd;wordStart-1<wordEn;wordEn--)wordEnding+=palinString.charAt(wordEn);
 if(wordBeginning.equals(wordEnding)){
  for(int palinWord = wordStart;palinWord<=wordEnd;palinWord++)System.out.print(palinString.charAt(palinWord));
  System.out.print("\n  ");
 } wordStart = wordEnd+2;
   }
 }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота