Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
DenKovYa
17.11.2021 01:06 •
Информатика
Паскаль вводится последовательность из n целых чисел. найти наибольшее из всех отрицательных чисел (без массива).
Показать ответ
Ответ:
sXiM
01.10.2020 22:49
Var
n, i, k, max: integer;
begin
readln(n);
for i := 1 to n do
begin
readln(k);
if ((k < 0) and ((max = 0) or (k > max))) then
max := k;
end;
writeln(max);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
dimapavlov2007
12.10.2022 03:29
Поздравительный файл расположен в папке как скачать файл...
Cat1235679
04.10.2020 08:31
Сколько единиц содержится в двоичной записи числа 16^100(степень) +7...
Wow019282
02.05.2020 17:35
напишите программуОпределить стоимость набора конфет, в который входят: Красная шапочка - X1 г, Алые паруса - X2 г, Чародейка - X3 г, если известна стоимость этих конфет...
kros222999
28.01.2023 05:26
Подскажите как делать такие рамки в ворде, точно такие же, в каком разделе и тд....
idkfndnf
08.06.2021 08:10
1. На які види поділяється програмне забезпечення? 2. Які види програм системного програмного забезпечення ви знаєте?3. Які програми відносяться до службових програм...
RADIUM24
06.04.2022 07:34
1.Які функції виконує програма POST? 2.Види сигналів програми POST. 3.У чому полягають особливості процедури програми POST?4.Характеризуйте діагностичні програми фірм-виробников...
ElvirO
15.10.2020 12:55
1.Які існують види діагностичних програм для контролю апаратних засобів IBM-сумісних комп’ютерів? 2. Назвіть тестування послідовних і паралельних портів.3.Характерізуйте...
veronikarub
04.08.2021 10:15
Замінити елементи списку, менші за середнє значення, нулями, а більші за середнє значення - одиницями (з прикладу: середнє значення 2.3, тому відповідь: 0 1 0 1 0 1...
armate
30.10.2020 16:52
Условия, состоящие из одной операции сравнения, называются: 1. линейными 2. сложными3. простыми4. составными...
neondragooffi
23.12.2022 20:21
0,7425 в 10 системы счисления. перевести в 2, 8,16 систему счисления.с проверкой!...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
n, i, k, max: integer;
begin
readln(n);
for i := 1 to n do
begin
readln(k);
if ((k < 0) and ((max = 0) or (k > max))) then
max := k;
end;
writeln(max);
end.