В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Wow019282
Wow019282
02.05.2020 17:35 •  Информатика

напишите программу

Определить стоимость набора конфет, в который входят: "Красная шапочка" - X1 г, "Алые паруса" - X2 г, "Чародейка" - X3 г, если известна стоимость этих конфет за 1 кг(S1, S2, S3 - все переменные - real). Вывод стоимости набора конфет - два знака после запятой.

Sample Input:

100 200 250 150 200 100
Sample Output:

80.00​

Показать ответ
Ответ:
Broxxi
Broxxi
18.02.2021 00:16

var x1, x2, x3, s1, s2, s3: real;

begin

read (x1, x2, x3, s1, s2, s3);

writeln(((x1 * s1 + x2 * s2 + x3 * s3) / 1000):0:2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота