В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nikemaxair55780
nikemaxair55780
01.11.2020 18:27 •  Информатика

Паскаль. Напишите программу, которая отделяет положительные элементы массива от отрицательных: переставляет все положительные (в том же порядке) в начало массива, а все отрицательные (в том же порядке) – в конец массива, все нулевые элементы должны оказаться в середине массива. входные данные:
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .
выходные данные:
Программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами.

Показать ответ
Ответ:
Эрайз
Эрайз
14.05.2023 19:03

signed main(){

   int n, m;

   cin >> n >> m;

   vector<vector<int>> a(n, vector<int> (m));

   for(int i = 0; i < n; i++)

       for(int j = 0; j < m; j++)

           cin >> a[i][j];

   int col = 0, mx = a[0][0];

   for(int i = 0; i < n; i++){

       for(int j = 0; j < m; j++){

           if(a[i][j] > mx){

               mx = a[i][j];

               col = j;

           }

       }

   }

   for(int i = 0; i < n; i++)

       swap(a[i][0], a[i][col]);

   for(int i = 0; i < n; i++){

       for(int j = 0; j < m; j++)

           cout << a[i][j] << " ";

       cout << "\n";

   }

}

0,0(0 оценок)
Ответ:
аня2838
аня2838
21.05.2023 13:25

14.9 (равнобедренные трапеции (с комментариями)):

#S=1/2h(a+b)

print ('Введите первое основание для первой трапеции')

af=int(input()) # Первое основание первой

print('Введите второе основание для первой трапеции')

bf=int(input()) # Второе основание первой

print('Введите высоту для первой трапеции')

hf=int(input()) # Высота первой

print ('Введите первое основание для второй трапеции')

aas=int(input()) # Первое основание второй

print ('Введите второе основание для второй трапеции')

bs=int(input()) # Второе основание второй

print ('Введите высоту для второй трапеции')

hs=int(input()) # Высота второй

pf=(af+bf)+af-bf)/2)**2+hf**2)**0.5)*2 #Периметр первой

ps=(aas+bs)+aas-bs)/2)**2+hs**2)**0.5)*2 #Периметр второй

sf=(af+bf)*hf/2 # Площадь первой

ss=(aas+bs)*hs/2 #Площадь второй

print ('Сумма периметров=', pf+ps)

print ('Сумма площадей=', sf+ss)

14.23 (Трехзначные простые числа):

for a in range (100,1000):

   b=0

   for i in range (2,a):

       if a%i==0:

           b+=1

   if b==0:

       print(a)

P.S: Вставлено из среды разработки, проверку на компиляторе программы

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота