Паскаль написать код Задача: Монеты У вас на столе лежит N монет. Некоторые из них лежат вверх решкой, а
некоторые - гербом. Определите минимальное число монет, которые нужно
перевернуть, чтобы все монеты были повернуты вверх одной и той же стороной.
// PascalABC.NET
// Версия 3.3.5 сборка 1662 (29.04.2018)
uses GraphABC;
begin
Window.Title := 'Рисование мышью(Enter - сохранить на раб. стол)';
Pen.Color := Color.Red;
Pen.Width := 3;
OnMouseDown := (x,y,mb) -> MoveTo(x,y);
OnMouseMove := (x,y,mb) -> if mb=1 then LineTo(x,y);
var a:=System.Security.Principal.WindowsIdentity.GetCurrent.Name;
OnKeyDown:=k->if k=13 then begin
SaveWindow('C:\Users\'+copy(a,pos('\',a)+1,a.Length-pos('\',a)+1)+'\Desktop\image.png'); Window.Close; end;
end.
uses crt;
const n=3;
var a: array [1..n,1..n] of integer;
x,y: integer;
begin
for x:=1 to n do begin
for y:=1 to n do begin
a[x,y]:=random(21)-10;
write(a[x,y]:4);
if a[x,y] mod 2=0 then a[x,y]:=0;
end;
writeln;
end;
writeln;
for x:=1 to n do begin
for y:=1 to n do
write(a[x,y]:4);
writeln;
end;
end.
2. Для матрицы 3*3 целых чисел найти индексы элементов с нулевым значением. Результат вывести на экран.
uses crt;
const n=3;
var a: array [1..n,1..n] of integer;
x,y: integer;
begin
for x:=1 to n do begin
for y:=1 to n do begin
a[x,y]:=random(21)-10;
write(a[x,y]:4);
end;
writeln;
end;
writeln;
for x:=1 to n do
for y:=1 to n do
if a[x,y]=0 then writeln(x,',',y);
end.