ПАСКАЛЬ.A. Странное сравнение Ограничение времени 1 секунда
Ограничение памяти 64Mb
Ввод стандартный ввод или compare.in
Вывод стандартный вывод или compare.out
Петя и Арсений готовятся идти в первый класс. Они очень волнуются: говорят, что к первому классу дети уже должны уметь и читать и писать и считать... Друзья знают цифры. Они решили поупражняться в сравнении чисел. Только вот математику они совсем не проходили... Числа они сравнивают так: смотрят на первую цифру, у какого числа первая цифра больше, то число они и считают большим. Напишите программу, сравнивающую числа по правилам Пети и Арсения.
Формат ввода
На вход программе поступают два примера, каждый в своей строке. Пример представляет собой два числа x и y, записанные через пробел. (1 ≤ x, y ≤ 1020) Числа x и y начинаются с различных цифр.
Формат вывода
Ваша программа должна вывести в первой строке единицу или двойку для первого примера, а во второй строке единицу или двойку для второго примера. 1 надо выводить, если первое число в примере больше по правилам детей, и 2, если больше по их правилам второе число.
Пример
Ввод Вывод
265 71
35 498
2
2
Формулы площадей квадрата S₁ и круга S₂ известны, что легко позволяет нам найти нужное условие.
Если нужно, чтобы случай, когда квадрат вписан в круг тоже учитывался, строгое неравенство следует заменить нестрогим.
// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
var s1:=ReadReal('Площадь квадрата');
var s2:=ReadReal('Площадь круга');
if pi*s1<2*s2 then Writeln('Квадрат умещается в круге')
else Writeln('Квадрат не умещается в круге')
end.
Тестовое решение:
Площадь квадрата 24.6
Площадь круга 28.4
Квадрат не умещается в круге
Разрядность шины - Системная шина процессора предназначена для обмена информацией микропроцессора с любыми внутренними устройствами микропроцессорной системы
Объем кэш-памяти - Кэш память процессора выполняет примерно ту же функцию, что и оперативная память. Только кэш - это память встроенная в процессор. Кэш-память используется процессором для хранения информации. В ней буферизируются самые часто используемые данные, за счет чего, время очередного обращения к ним значительно сокращается.
Количество ядер в домашних системах от одного до четырех