В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
llllllllllllll1
llllllllllllll1
07.07.2020 07:22 •  Информатика

(PASCAL)Напишите программу для решения следующей задачи. Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите самую низкую температуру за время наблюдения. Если температура опускалась ниже –15 градусов, выведите YES, иначе выведите NO. Программа получает на вход количество дней, в течение которых проводилось измерение температуры N (1 ≤ N ≤ 31), затем для каждого дня вводится температура. Пример работы программы:

Входные данные

4

–5

12

–2

8

Выходные данные

–5

NO

Показать ответ
Ответ:
DmitriyWayne557
DmitriyWayne557
21.01.2021 17:04

var x:integer;

n: array[1..31] of integer;

begin

 for var i:=1 to 31 do

 begin

   write('Введите температуру ',i,' дня: '); readln(n[i]);

   if n[i]<x then x:=n[i];

 end;

 writeln; writeln('Минимальная тепература: ',x);

 if x<-15 then writeln('YES') else writeln('NO');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота