В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Cuba125
Cuba125
19.02.2022 20:10 •  Информатика

Pascal написать программу проверяющую есть ли в заданном слове две подряд идущие одинаковые буквы

Показать ответ
Ответ:
shalamova07200
shalamova07200
30.09.2020 15:47

program raf105;

var  

s:string;

x:boolean;

i:integer;

begin

write('Введите слово: ');

readln(s);

s:= lowercase(s);

for i:=2 to length(s) do

 if not x

   then x:= s[i] = s[i-1];

if x

 then writeln('В слове есть две подряд идущие, одинаковые буквы')

 else writeln('В слове нет двух подряд идущих, одинаковых букв');

end.

Язык PascalABC

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота