Решать через паскаль! даны числа n и m. создайте массив a[n][m] и заполните его змейкой (см. пример). входные данные программа получает на вход два числа n и m. выходные данные программа должна вывести полученный массив, отводя на вывод каждого числа ровно 3 символа. примеры входные данные 4 10 выходные данные 0 1 2 3 4 5 6 7 8 9 19 18 17 16 15 14 13 12 11 10 20 21 22 23 24 25 26 27 28 29 39 38 37 36 35 34 33 32 31 30 я написала программу всё правильно ,но она начинается не с нуля исправьте ошибку: var a: array[1..100,1..100] of integer; i,j,n,m: integer; begin readln(n,m); for i: =1 to n do begin for j: =1 to m do begin if i mod 2=1 then a[i,j]: =(i-1)*m+j else a[i,j]: =i*m-j+1; write(a[i,j]: 3); end; writeln; end; end. 4 10 1 2 3 4 5 6 7 8 9 10 20 19 18 17 16 15 14 13 12 11 21 22 23 24 25 26 27 28 29 30 40 39 38 37 36 35 34 33 32 31