В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
yliana23
yliana23
02.11.2022 13:20 •  Информатика

Pascal Дан массив, содержащий 20 положительных целых чисел, не превышающих 30 000. Необходимо найти в этом массиве количество элементов, которые кратны 3, а их десятичная запись заканчивается цифрой 1, и заменить каждый из таких элементов на это количество. Напишите программу для решения этой задачи. В качестве результата программа должна вывести изменённый массив, по одному элементу в строке. Например, для исходного массива из 5 элементов

15 71 21 111 41

программа должна вывести (по одному числу в строке) числа

15 71 2 2 41.

Показать ответ
Ответ:
alesaastudinap0dbun
alesaastudinap0dbun
26.09.2022 08:08

print("Ноль в качестве знака операции"

     "\nзавершит работу программы")

while True:

   s = input("Знак (+,-,*,/): ")

   if s == '0':

       break

   if s in ('+', '-', '*', '/'):

       x = float(input("x="))

       y = float(input("y="))

       if s == '+':

           print("%.2f" % (x+y))

       elif s == '-':

           print("%.2f" % (x-y))

       elif s == '*':

           print("%.2f" % (x*y))

       elif s == '/':

           if y != 0:

               print("%.2f" % (x/y))

           else:

               print("Деление на ноль!")

   else:

       print("Неверный знак операции!")

0,0(0 оценок)
Ответ:
vdhfhsbh
vdhfhsbh
10.04.2021 09:09

var a,k3,k4,k5,i: integer;

cr:real;

begin

 k3:=0;

 k4:=0;

 k5 := 0;

 cr:=0;

 for i:=1 to 20 do

 begin

   writeln('введите оценку ученика');

   readln (a);

   cr:=cr+a;

   if a mod 3=0 then k3:=k3+1 else if a mod 4= 0 then k4:=k4+1 else k5:=k5+1;

     end;

 writeln('число отметок 5,полученных учениками за контрольную работу:',k5);

 cr:=cr/20;

 writeln('Средний , полученный учениками за контрольную работу:',cr);

 if (k5>k4) and (k5>k3) then writeln('пятерок больше всего')  

 else if (k4>k3) then writeln('четверок больше всего')

 else writeln('троек больше всего')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота