В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
natalika79
natalika79
25.10.2021 05:07 •  Информатика

Папа васи, программист известной компьютерной фирмы, решил проверить внимательность васи. он взял 16 карточек, на каждой из которых написал одно из 16-ти чисел натурального ряда от 1 до 16 и разложил все карточки в порядке возрастания изображенных на них чисел. затем он на каждой карточке написал еще по два числа: одно из которых равно остатку от деления числа на карточке на число 3, а другое - остатку от деления числа на карточке на число 5.
потом он выполнил следующий алгоритм для составления новой последовательности карточек:
1. выбрать из первоначального ряда карточек по порядку все карточки, у которых хотя бы один из остатков от деления на числа 3 или 5 равен нулю.
2. из оставшихся карточек первоначального ряда выбрать по порядку все карточки, у которых хотя бы один из остатков равен 1.
3. затем из оставшихся карточек первоначального ряда выбрать по порядку все карточки, где в качестве остатка от деления встречается число 2.
вот что у него в итоге получилось:
3, 5, 6, 9, 10, 12, 15, 1, 4, 7, 11, 16, 2, 8, 13, 14
вася, будучи старательным и ответственным во всем человеком, проверил правильность получившегося у папы порядка расположения карточек и обнаружил, что одна карточка оказалась не на своем месте. найдите и вы эту карточку. в ответе укажите через пробел два числа: первое – значение числа, которое оказалось на неправильном месте, второе – значение числа в новой последовательности, за которым следует разместить ошибочную карточку.

Показать ответ
Ответ:
mrskelet7
mrskelet7
19.04.2021 12:59

a = int(input())

for i in range(a):

 b = input()

 c = 0

 d = True

 e = 0

 f = False

 g = False

 h = '\''

 for j in b:

   if j == '#' and not f:

     g = True

     break

   elif j != ' ':

     if d:

       print(' ' * c, end='')

     elif c > 0:

       print(' ', end='')

     c = 0

     print(j, end='')

     if(j == '\"' or j == '\'') and e % 2 == 0:

       if f and j == h:

         f = False

       else:

         f = True

         h = j

     if f:

       d = True

     else:

       d = False

     if j == '\\':

       e += 1

     else:

       e = 0

   else:

     c += 1

   r = j == ' '

if g and c > 1:

 print(' ', end='')

if i < a - 1:

 print()

1

Объяснение:

0,0(0 оценок)
Ответ:
Daswert
Daswert
17.05.2022 14:08

var

 x, y, t, c, n, k: integer;

 a: array [1..10] of integer;

begin

 for t := 1 to 10 do

   a[t] := 0;

 read(x, y);

 t := x;

 while (t <> 0) do

 begin

   c += 1;

   t := t div 10;

 end;

 k := 1;

 for t := 1 to c do

   k *= 10;

 while (x <> 0) do

 begin

   n := y;

   t := x div k;

   while (n <> 0) do

   begin

     c := n mod 10;

     n := n div 10;

     if (c = t) and (a[c + 1] = 0) then

     begin

       write(t, ' ');

       a[c + 1] += 1;

       break;

     end;

   end;

   x := x mod k;

   k := k div 10;

 end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота