В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Нужно написать программу в паскале. : введите возраст человека от 1 до 150 и выведите его вместе со словом "год","года",лет".

Показать ответ
Ответ:
docogov
docogov
27.05.2020 11:57

var
a:byte;
begin
readln(a);
if ((a<11) or ((a>14) and (a<110)) or (a>114)) and (a mod 10<5) and (a mod 10>1) then
writeln(a,' года') else
if (a mod 10=1) and (a<>11) and (a<>111) then
writeln(a,' год') else
writeln(a,' лет');
readln;
end.

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота