В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ПолинаТ1
ПолинаТ1
29.06.2020 16:36 •  Информатика

Отношение Дан массив a1,a2,…an. Необходимо выбрать в нём два элемента ai и aj, такие что i
Входные данные

В первой строке задано целое число 2 ≤n≤ 100 000 — количество элементов в массиве.

Во второй строке заданы n целых положительных чисел ai(1 ≤i≤n, 1 ≤ai≤ 5000).

Выходные данные

Выведите два числа — индексы элементов i и j. Если ответов несколько, то выведите любой из них.

Если ответа нет, то выведите два нуля, разделённых пробелом.

Показать ответ
Ответ:
kicked102
kicked102
25.06.2021 19:19

Нужно определить, сколько времени будет передаваться файл объемом 5 Мбайт по каналу со скоростью передачи данные 215 бит/с; к этому времени нужно добавить задержку файла у Толи (пока он не получит 512 Кбайт данных по каналу со скоростью 219 бит/с). 

Периведём объём информации в Мб в биты: Q = 5 Мб = 5 * 220 байт = 5 * 223 бит. 

Время задержки:  = 512 кб / 219 бит/с = 2(9 + 10 + 3) - 19 c = 23 c. 

Время скчивания данных Мишей:  = 5 * 223 бит / 215 бит/с = 5 * 28 c. 

Полное время:  = 5 * 28 c + 23 c = (256 * 5 + 8) c = 1288 c. 

ответ: 1288.

0,0(0 оценок)
Ответ:
Canyon77
Canyon77
10.07.2020 17:45
12 задание

#include <iostream>

using namespace std;

int main()

{

   for(double i = 1; i <=25; ++i)

   {

       if(((int)i-1)%5==0)

       {

           cout << endl;

       }

       cout << "Earth - " << i << ", moon - " << i*0.17 << endl;

   }

   cin.get();

}

14 задание

#include <iostream>

using namespace std;

int main()

{

   double num,sum=0;

   for(int i=0; i < 5;++i)

   {

       cout << "Enter number #" << i+1 << " -> ";

       cin >> num;

       sum+=num;

   }

   cout << "Average: " << sum/5 << endl;

   cin.get();

   cin.get();

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота