Определите, что выведет на экран программа при вызове F(7).
procedure F(n: integer); forward;
procedure G(n: integer); forward;
procedure F(n: integer);
begin
n := n - 1;
if n > 2 then
begin
write(n);
F(n - 1);
G(n - 2);
end
else
write(n+2);
end;
procedure G(n: integer);
begin
write(n);
if n > 2 then
begin
n := n - 1;
G(n - 1);
F(n - 2);
end
end;
Распишите по действиям
Вычти квадрат и возведи
Объяснение:
Первая из них уменьшает число на экране на 1, вторая возводит его во вторую степень. Исполнитель работает только с натуральными числами. Составьте алгоритм получения из числа 2 числа 64, содержащий не более 5 команд. В ответе запишите только номера команд. (Например, 11121 — это алгоритм: вычти 1, вычти 1, вычти 1, возведи в квадрат, вычти 1, который преобразует число 7 в 15.) Если таких алгоритмов более одного, то запишите любой из них.
C++
Объяснение:
#include <iostream>
using namespace std;
const int maxCount = 1000;
int main() {
int i, count;
int *arr;
cout << "Input count elements: ";
cin >> count;
if(count <= maxCount) {
arr = new int[count];
int st = 0;
cout << "Input elements array" << endl;
for(i = 0;i < count;i++) {
cin >> arr[i];
if(arr[i] > 70) {
st++;
}
}
cout << "Result: " << st;
}
else {
cout << "Error!" << endl;
}
return 0;
}