В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
саид126
саид126
26.11.2022 11:08 •  Информатика

Написать программу, которая будет вводить с клавиатуры положительные числа до тех пор, пока не будет введена -1. все числа должны записываться в один список и в конце работы программы из списка должны быть распечатаны сначала четные, затем не четные. на python

Показать ответ
Ответ:
sergeyblack11
sergeyblack11
09.10.2020 14:03
Не очень корректное решение, но выводит вроде бы правильно

total = []
n = int(input())
total.append(n)
while n >= 0:
   n = int(input())
   total.append(n)
del total[-1]
for k in total:
   if k % 2 == 0:
       print(k)
   else:
       print(k)

Ссылка на код: https://pastebin.com/cRTRMS3L
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота