В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
poseido2008p04tk8
poseido2008p04tk8
24.10.2022 12:47 •  Информатика

Определен алгоритм обработки массива. На вход подается массив натуральных чисел, который обрабатывается следующим образом: - сначала все числа, которые кратны и 3, и 5 одновременно, заменяются на число -13;
- затем все числа кратные 3 заменяются на число -7;
- затем все числа кратные 5 заменяются на число -11.
Вася выполнил алгоритм, подав на вход массив, заполненный последовательностью натуральных чисел от 1 до N включительно, и вывел получившийся после обработки массив. Укажите такое N, при котором будет выведено “-7” – 11 раз, “-11” – 5 раз, “-13” – 2 раза. В ответе укажите целое число. Если таких значений несколько, укажите максимальное из них.

Показать ответ
Ответ:
НастюшКа50471
НастюшКа50471
12.11.2022 22:14
Задание 1

Так как в записи числа может присутствовать цифра 7, то система счисления называется 7 + 1 = восьмеричной (3)

Задание 2

Так как в записи числа присутствует число 5, то данное число существует во всех системах счисления, больших 5, то есть 6, 7, 8, 9, 10 и так далее (1, 3 (какая там система счисления? - речная), 4)

Задание 3

101₂ = 100 + 1 = 11 + 1 + 1 = 10 + 1 + 1 + 1 = 1 + 1 + 1 + 1 + 1. Так как единица в двоичной системе равна единице в десятичной системе, то складываем и получаем ответ 5 (2)

Задание 4

Только над целыми (1)

Задание 5

a = 8;

b = 6 + 3 · a = 6 + 3 · 8 = 30

Так как нам нужно определить именно значение b, то вычислять значение переменной a не имеет смысла.

Задание 6

begin - оператор открытия основного блока, read - чтение значения переменных, wrircln - бред, а print - вывод (4)

0,0(0 оценок)
Ответ:
reopla
reopla
14.09.2020 15:07
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  for var a:=1 to 10 do begin
    Writeln('Длина стороны ',a,' см');
    for var b:=1 to 10 do
      Writeln('Вторая сторона ',b:2,', периметр ',2*(a+b):2,
          ', площадь ',a*b:3)
    end
end.

Результат
Длина стороны 1 см
Вторая сторона  1, периметр  4, площадь   1
Вторая сторона  2, периметр  6, площадь   2
Вторая сторона  3, периметр  8, площадь   3
Вторая сторона  4, периметр 10, площадь   4
Вторая сторона  5, периметр 12, площадь   5
Вторая сторона  6, периметр 14, площадь   6
Вторая сторона  7, периметр 16, площадь   7
Вторая сторона  8, периметр 18, площадь   8
Вторая сторона  9, периметр 20, площадь   9
Вторая сторона 10, периметр 22, площадь  10
Длина стороны 2 см
Вторая сторона  1, периметр  6, площадь   2
Вторая сторона  2, периметр  8, площадь   4
Вторая сторона  3, периметр 10, площадь   6
Вторая сторона  4, периметр 12, площадь   8
Вторая сторона  5, периметр 14, площадь  10
Вторая сторона  6, периметр 16, площадь  12
Вторая сторона  7, периметр 18, площадь  14
Вторая сторона  8, периметр 20, площадь  16
Вторая сторона  9, периметр 22, площадь  18
Вторая сторона 10, периметр 24, площадь  20
Длина стороны 3 см
Вторая сторона  1, периметр  8, площадь   3
Вторая сторона  2, периметр 10, площадь   6
Вторая сторона  3, периметр 12, площадь   9
Вторая сторона  4, периметр 14, площадь  12

Длина стороны 10 см
Вторая сторона  1, периметр 22, площадь  10
Вторая сторона  2, периметр 24, площадь  20
Вторая сторона  3, периметр 26, площадь  30
Вторая сторона  4, периметр 28, площадь  40
Вторая сторона  5, периметр 30, площадь  50
Вторая сторона  6, периметр 32, площадь  60
Вторая сторона  7, периметр 34, площадь  70
Вторая сторона  8, периметр 36, площадь  80
Вторая сторона  9, периметр 38, площадь  90
Вторая сторона 10, периметр 40, площадь 100
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота