Очень Напишите программу подсчета количества положительных, количества нулевых и количества отрицательных элементов массива. Проверьте работу программы на заданном массиве А = {7, 25, 4.5, 0, 17, 61, -10, 0, 1, -4, 22}.
Кол-во полож. элементов:
Кол-во нулевых элементов:
Кол-во отриц. элементов:
var
a:array [1..11] of real;
i,s1,s2:integer;
begin
s1:=0; s2:=0;
for i:=1 to 11 do
begin
readln(a[i]);
if a[i]>0 then
inc(s1)
else
if a[i]<0 then
inc(s2);
end;
writeln('<0: ', s2);
writeln('>0: ', s1);
writeln('=0: ', i-s1-s2);
end.