Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
komkov2
11.08.2021 08:46 •
Информатика
Напишите программу для определения суммы четных чисел из n первых чисел фибоначчи. в прологе
Показать ответ
Ответ:
Владивостокер
17.11.2021 12:49
#include <iostream>
/*Библиотека стандартного ввода-вывода C++ */
#include <string>
/*строки*/
#include <cstdio>
//Библиотека стандартного ввода-вывода C*/
using namespace std;
int main()
{
short int maxDigit = -1;
string str;
printf("%s","Введите строку: ");
cin >> str;
/*Ввод строки*/
for(int i = 0; str[i] != '\0'; i++)
/*Цикл от начала строки до ее конца*/
/*('\0' - "нуль-терминатор" это символ конца строки)*/
{
if((isdigit(str[i])) && (short int)(str[i]-48)>maxDigit)
/*Если текуший символ цифра и она больше maxDigit)*/
/*"(short int)...-48" преобразует char в short int*/
maxDigit = (short int)(str[i]-48);
/*То maxDigit = этой цифре.*/
}
if(maxDigit == -1) cout << "В строке нет цифр: " << "\n";
cout << "Наибольшая цифра: " << maxDigit << "\n";
/*Вывод */
system("pause");
return 0;
}
0,0
(0 оценок)
Ответ:
mooziviycom
01.10.2020 15:37
// PascalABC.NET 3.3, сборка 1633 от 10.02.2018
// Внимание! Если программа не работает, обновите версию!
№1
begin
var x:=ReadReal('x=');
var y:=Sqr((1-x*x+5*Sqr(x*x)));
Writeln('y=',y)
end.
Пример
x= 4.12
y=2029704.2032886
2a.
begin
var x:=ReadReal('x=');
var t1:=x*x; // x^2
var t2:=t1*t1; // x^4
t2:=t2*t2; // x^8
t1:=t2*t1; // x^10
Writeln('x^10=',t1)
end.
2b.
begin
var x:=ReadReal('x=');
var t:=x*x; // x^2
t:=t*t; // x^4
t:=t*t; // x^8
t:=t*t; // x^16
t:=t/x; // x^15
Writeln('x^15=',t)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
раовт
22.06.2021 02:44
Дано N положительных целых чисел. Сколько среди них четных трехзначных...
akonbkaru
12.02.2023 19:03
вопрос информатикаток честно...
malia1011
19.01.2023 10:54
решить задания по информатике...
343463165313
10.04.2020 10:39
BПPфункциясынын манызы не де...
Gora583Иришка
21.02.2023 03:31
- охпернетOnline Mektep-BilimLandО КТПР 2017 B BilimLand 0 ScratchКегль-ринг. Урок 1ек отзывов вк1aИзучи предложенную таблицу и определи закономерность изменения значенийоборотов...
7Rahat
03.12.2022 03:27
ЧТО ИЗ ЭТОГО СИСТЕМНЫЕ ПРОГРАММЫ? WinRar Gimp MS Word Java C++ Pascal Avast...
Sawa1605
27.06.2020 15:21
Какой минимальный объем памяти (в Кбайт) нужно зарезервировать, чтобы можно было сохранить растровое изображение размером 720 на 720 пикселей при условии, что а изображении...
Свєтлана1
14.08.2022 21:04
Как это решить? Не уставливается дальше. Уже пробовал заного скачать все также ...
lika1vulvach
01.06.2023 09:52
7) Дисплей работает с 16-и цветной палитрой в режиме 64 * 128 пикселей. Укажите объем видеопамяти....
smellofcherry
15.03.2020 17:38
Задан одномерный массив А, содержащий N элементов. Значения всех элементов массива различны. Укажите, что будет определено в результате работы следующего фрагмента программы:...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
/*Библиотека стандартного ввода-вывода C++ */
#include <string>
/*строки*/
#include <cstdio>
//Библиотека стандартного ввода-вывода C*/
using namespace std;
int main()
{
short int maxDigit = -1;
string str;
printf("%s","Введите строку: ");
cin >> str;
/*Ввод строки*/
for(int i = 0; str[i] != '\0'; i++)
/*Цикл от начала строки до ее конца*/
/*('\0' - "нуль-терминатор" это символ конца строки)*/
{
if((isdigit(str[i])) && (short int)(str[i]-48)>maxDigit)
/*Если текуший символ цифра и она больше maxDigit)*/
/*"(short int)...-48" преобразует char в short int*/
maxDigit = (short int)(str[i]-48);
/*То maxDigit = этой цифре.*/
}
if(maxDigit == -1) cout << "В строке нет цифр: " << "\n";
cout << "Наибольшая цифра: " << maxDigit << "\n";
/*Вывод */
system("pause");
return 0;
}
// Внимание! Если программа не работает, обновите версию!
№1
begin
var x:=ReadReal('x=');
var y:=Sqr((1-x*x+5*Sqr(x*x)));
Writeln('y=',y)
end.
Пример
x= 4.12
y=2029704.2032886
2a.
begin
var x:=ReadReal('x=');
var t1:=x*x; // x^2
var t2:=t1*t1; // x^4
t2:=t2*t2; // x^8
t1:=t2*t1; // x^10
Writeln('x^10=',t1)
end.
2b.
begin
var x:=ReadReal('x=');
var t:=x*x; // x^2
t:=t*t; // x^4
t:=t*t; // x^8
t:=t*t; // x^16
t:=t/x; // x^15
Writeln('x^15=',t)
end.