В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
epicrare15
epicrare15
11.04.2022 23:30 •  Информатика

Нужно написать программу на С++
Даны две квадратные вещественные матрицы порядка 5 и 8. В каждой матрице вычислить
произведение элементов под главной диагональю и сумму элементов над главной
диагональю. Использовать функции.

Показать ответ
Ответ:
supanzerbe
supanzerbe
17.01.2022 01:57
1.

n = int(input("Введите сколько чисел вы хотите ввести: "))

a = []

for x in range(1, n + 1):

   a.append(int(input("Введите число " + str(x) + ": ")))

s = 0

for x in range(0, len(a)):

   s += a[x]

print("Среднее арифметическое всех чисел:", s/len(a))

2.

print("Числа, которые задумал Ипполит: ")

for x in range(100, 1000):

   if x % 15 == 11 and x % 11 == 9:

       print(x)

3.

n = int(input("Введите сколько чисел вы хотите ввести: "))

a = []

for x in range(1, n + 1):

  a.append(int(input("Введите число " + str(x) + ": ")))

c = []

n = []

p = 0

for x in range(0, len(a)):

   if a[x] % 2 == 0:

       c.append(a[x])

   elif a[x] % 2 != 0:

       n.append(a[x])

   if a[x] > 0:

       p += 1

u = 1

s = 0

for x in range(0, len(c)):

   u *= a[x]

for x in range(0, len(n)):

   s += a[x]

print("Произведение четных чисел:", u)

print("Сумма нечетных чисел:", s)

print("Количество положительных чисел:", p)

0,0(0 оценок)
Ответ:
anna200521
anna200521
14.03.2021 22:47
Преобразуем выражение к виду, из которого легко перевести в шестеричную систему, затем переведём в неё и посчитаем, сколько получится:

36^17+66^6-6=66^6+(6^2)^12-6=66^6+6^(2*12)-6=66^6+6^24-6^1=(1*6^36+1*6^24)-1*6^1=1000000000001000000000000000000000000^6-10^6=1000000000000555555555555555555555550^6

Как видим, была разность двух чисел в шестеричной системе счисления.
Первое число состояло из двух единиц и кучи нулей.
Вторая единица- после неё было 24 нуля (т.к. в шестеричной системе и есть единица с 24-мя нулями).
Потом мы вычли из этого единицу с одним нулём.
Получается, у нас из этих 24-ёх нулей, последний останется, а вместо остальных 23-ёх будут стоять пятёрки. Ну, а вместо второй единицы будет ноль.

Итого, в этой записи будет 23 пятёрки.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота