Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
KsKitty
24.10.2022 13:43 •
Информатика
Нужно написать программу, которая переводит число из 16-ой сс в 10-ю сс, на языке c.
Показать ответ
Ответ:
ого23
07.10.2020 06:39
#include <stdio.h>
int main(void) {
int n;
printf("Введите число в 16-ричной СС: ");
scanf("%x",&n);
printf("%x(16) = %d(10)",n,n);
return 0;
}
Пример:
Введите число в 16-ричной СС: a1f
a1f(16) = 2591(10)
0,0
(0 оценок)
Популярные вопросы: Информатика
hfdgddcju
28.01.2022 06:34
Задание 1 Построить в домашнем каталоге /home/groups/v100/v100-1 следующее дерево (синим изображены каталоги, чёрным - файлы с текстом). Задание 2 Переместите все файлы в каталог...
Ыыыап
22.08.2022 10:56
Запиши строку программу, в которой запрашивается (вводится) значение переменной m вещественного типа с клавиатуры...
MartinaStoessel2
10.02.2020 14:09
9. Между населёнными пунктами A, B, C, D, E, F построены дороги, протяжённость которых приведена в таблице. Определите длину кратчайшего пути между пунктами А и Е. A В с D E...
никита16l
19.08.2021 16:59
Составить программу вычисления значения функции y=x2...
Dimitriy2281
25.06.2020 12:48
Информатика ( П.О.М.О.Г.И.Т.Е)...
аличка77
02.06.2022 08:58
Хелп любые 2. Информатика...
FeliceMell
13.02.2021 18:43
Как будет преобразовано число 60, если исполнитель выполнит алгоритм: aabab....
lovevika3
19.05.2023 13:54
Склавиатуры вводятся натуральные числа a и n. найти сумму n четных чисел, начиная с a....
tuiyty
25.05.2021 04:08
Двое по очереди ломают шоколадку 4*9. за ход можно разломать любой кусок прямой линии между дольками. проигрывает тот, кто не может сделать ход. кто выиграет?...
dastanemilbeko
23.10.2022 18:42
Краткое содержание тихое утро юрий казаков.предложений 5-7...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
int main(void) {
int n;
printf("Введите число в 16-ричной СС: ");
scanf("%x",&n);
printf("%x(16) = %d(10)",n,n);
return 0;
}
Пример:
Введите число в 16-ричной СС: a1f
a1f(16) = 2591(10)