Нужна блок схема :Составить программу, которая находит все пары положительных целых чисел х, у , удовлетворяющих уравнению А*х+В*у=С, где А, В, С - натуральные числа, причем С>max(A,B).
A3. Для групповых операций с файлами используются маски имен файлов. Маска представляет собой последовательность букв, цифр и прочих допустимых в именах файлов символов, в которых также могут встречаться следующие символы: Символ «?» (вопросительный знак) означает ровно один произвольный символ. Символ «*» (звездочка) означает любую последовательность символов произвольной длины, в том числе «*» может задавать и пустую последовательность. Определите, по какой из масок будет выбрана указанная группа файлов
abcd.txt, bc.tel, bcd.txt, bc.tel
1) *bc*.?t* 2) ?bc?.t?? 3) ?bc?.t* 4) *bc*.t??
Решение: Имя файла состоит из идентификатора и расширения, разделенных точкой. Идентификаторы указанной группы имеют разную длину, но в каждом идентификаторе присутствуют символы bc, следовательно, исходя из определения шаблона «*» идентификатор маски можно задать в виде: *bc*. Расширение у всей группы файлов состоит из трех символов, причем, первый символ после точки у всех четырех файлов – одинаковый – t. Cледовательно, для расширения надо использовать шаблон «t??». Чтобы выбрать указанную группу файлов должна быть задана следующая маска: *bc*.t??
int hexCharToDec(char hexChar) { switch (hexChar) { case 'a': return 10; break; case 'b': return 11; break; case 'c': return 12; break; case 'd': return 13; break; case 'e': return 14; break; case 'f': return 15; break; default: return hexChar - 48; break; } }
int hexToDec(string hexString) { std::transform(hexString.begin(), hexString.end(), hexString.begin(), ::tolower); int power = 0, ret = 0; for (string::reverse_iterator rit = hexString.rbegin(); rit != hexString.rend(); ++rit) { ret += hexCharToDec(*rit) * pow(16, power); power++; } return ret; }
A3. Для групповых операций с файлами используются маски имен файлов. Маска представляет собой последовательность букв, цифр и прочих допустимых в именах файлов символов, в которых также могут встречаться следующие символы: Символ «?» (вопросительный знак) означает ровно один произвольный символ. Символ «*» (звездочка) означает любую последовательность символов произвольной длины, в том числе «*» может задавать и пустую последовательность. Определите, по какой из масок будет выбрана указанная группа файлов
abcd.txt, bc.tel, bcd.txt, bc.tel
1) *bc*.?t* 2) ?bc?.t?? 3) ?bc?.t* 4) *bc*.t??
Решение: Имя файла состоит из идентификатора и расширения, разделенных точкой. Идентификаторы указанной группы имеют разную длину, но в каждом идентификаторе присутствуют символы bc, следовательно, исходя из определения шаблона «*» идентификатор маски можно задать в виде: *bc*. Расширение у всей группы файлов состоит из трех символов, причем, первый символ после точки у всех четырех файлов – одинаковый – t. Cледовательно, для расширения надо использовать шаблон «t??». Чтобы выбрать указанную группу файлов должна быть задана следующая маска: *bc*.t??
#include <string>
#include <math.h>
#include <algorithm>
using namespace std;
int hexCharToDec(char hexChar)
{
switch (hexChar) {
case 'a':
return 10;
break;
case 'b':
return 11;
break;
case 'c':
return 12;
break;
case 'd':
return 13;
break;
case 'e':
return 14;
break;
case 'f':
return 15;
break;
default:
return hexChar - 48;
break;
}
}
int hexToDec(string hexString)
{
std::transform(hexString.begin(), hexString.end(), hexString.begin(), ::tolower);
int power = 0, ret = 0;
for (string::reverse_iterator rit = hexString.rbegin(); rit != hexString.rend(); ++rit) {
ret += hexCharToDec(*rit) * pow(16, power);
power++;
}
return ret;
}
int main()
{
string s;
cout << "Строка: ";
cin >> s;
cout << endl << "ответ: " << hexToDec(s) << endl;
return 0;
}