В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
danilkalmykov1
danilkalmykov1
26.07.2021 10:29 •  Информатика

Найти среднее арифметическое элементов одномерного массива а10. составить программу.

Показать ответ
Ответ:
арипов1
арипов1
26.05.2020 06:57

Допустим, что все элементы должны быть положительными.

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int main()
{
   int a[10] = { 5, 2, 8, 21, 17, 9, 0, 3, 1, 2 };
   float mean = 0;

   for(int i = 0; i < 10; i++)
   {
      cout << a[i] << ' ';

      mean += a[i]; //Найти сумму всех элементов
   }

   mean /= 10;

   cout << "\nArithmetic mean = " << mean << endl;

   return 0;
}


Найти среднее арифметическое элементов одномерного массива а10. составить программу.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота