В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
mariapodgornova
mariapodgornova
17.12.2022 11:26 •  Информатика

Напишите в питоне Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:

F(n) = n, при n ≤ 3

при n > 3:

F(n) = n + F(n–1), при чётном n;

F(n) = n*n + F(n-2), при нечётном n;

Определите количество натуральных значений n, при которых F(n) меньше, чем 10^8.

Показать ответ
Ответ:
sinjay
sinjay
29.06.2021 21:34

def f(n):

   if n <= 3:

       return n

   elif n % 2 == 0:

       return n + f(n - 1)

   else:

       return n*n + f(n-2)

cur = 1

while(f(cur) < 1e8):

   cur += 1

print(cur - 1)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота