В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Арсен077
Арсен077
29.01.2023 14:54 •  Информатика

Напишите программы в Pascal.
1. Напишите программу, которая определяет число учеников в классе, чей вес
превышает средний.
2. Напишите программу вычисления расстояния между точками А и В, если известны
координаты xA, yA, xB, yB.
3. Напишите программу нахождения всех двухзначных чисел и вычисления их
суммы.

Показать ответ
Ответ:
настя123456789108
настя123456789108
21.03.2022 05:26
Чтобы квадрат вписался в круг, его диагональ должна быть равна диаметру круга. Если трактовать "уместиться" как "пролезть", то диагональ должна быть меньше диаметра..
Формулы площадей квадрата  S₁ и круга S₂ известны, что легко позволяет нам найти нужное условие.
\displaystyle S_1=a^2 \to a=\sqrt{S_1}; \ d=a \sqrt{2}= \sqrt{2S_1} \\ S_2=\frac{\pi D^2}{4} \to D=\sqrt{\frac{4S_2}{\pi}}; \\ d\ \textless \ D \to \sqrt{2S_1}\ \textless \ \sqrt{\frac{4S_2}{\pi}}; \ 2S_1\ \textless \ \frac{4S_2}{\pi} \ \to \ \boxed{\pi s_1\ \textless \ 2S_2}
Если нужно, чтобы случай, когда квадрат вписан в круг тоже учитывался, строгое неравенство следует заменить нестрогим.

// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
  var s1:=ReadReal('Площадь квадрата');
  var s2:=ReadReal('Площадь круга');
  if pi*s1<2*s2 then Writeln('Квадрат умещается в круге')
  else Writeln('Квадрат не умещается в круге')
end.

Тестовое решение:
Площадь квадрата 24.6
Площадь круга 28.4
Квадрат не умещается в круге
0,0(0 оценок)
Ответ:
letujio
letujio
05.11.2022 06:13

#include<iostream>

#include<ctime>

#include<stdlib.h>

using namespace std;

int main() {

setlocale(LC_ALL, "russian");

const int  ROWS = 500;//строки

const int  COLS = 500;//колонки

int arr[ROWS][COLS];

/*заполнение массива*/

for (int i=0; i<ROWS; i++) {

 for (int j=0; j<COLS; j++) {

  arr [i][j] = rand() % 2;

 }

}

/*вывод массива*/

for (int i=0; i<ROWS; i++) {

 for (int j=0; j<COLS; j++) {

  cout<<arr[i][j]<<"\t";

 }

 cout<<endl;

}

}

Объяснение:

setlocale(LC_ALL, "russian") не обязательно...

Можно лучший ответ , ОЧНЬ надо :

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота