В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Alexgk13
Alexgk13
10.12.2022 03:17 •  Информатика

Напишите программу, заполняющую одномерный массив случайными числами, и подсчитывающий количество элементов из диапазона от 20 до 40 ,или печатающих что таких нет

Показать ответ
Ответ:
2006215
2006215
02.10.2020 01:47
GNU GCC.

#include <iostream>
#include <vector>
#include <cstdlib>
using namespace std;

int main()
{
int a, b, n;
cout <<"Введите границы диапазона и размер массива:" <<endl;
cin >>a >>b >>n;
if(n>10000) n=10000;
vector<int> v(n);
srand(time(0));
cout <<"Исходный массив:" <<endl;
for(int i=0; i<v.size(); ++i)
{
v[i] = rand()%(b-a+1) + a;
cout <<v[i] <<" ";
}
cout <<"\n3х-значные элементы, не кратные 5:" <<endl;

for (int i=0; i<v.size(); ++i)
if ((v[i]>99) && (v[i]<1000) && (v[i]%5!=0))
cout <<v[i] <<" ";
cout <<endl;

return 0;
}
0,0(0 оценок)
Ответ:
elizamir808
elizamir808
20.02.2021 12:03
Программа:
const m=7; n=8;
var t:array[1..m,1..n] of integer;
i,j:integer; s,max:real;
begin
Randomize;
writeln('Результаты измерений:');
writeln('   0   3   6   9  12  15  18  21');
writeln(' ');
for i:=1 to m do
 begin
 for j:=1 to n do
  begin
   t[i,j]:=random(10)-5;
   write(t[i,j]:4);
  end;
  writeln;
 end;
max:=-200;
for i:=1 to m do
 begin
 s:=0;
 for j:=1 to n do s:=s+t[i,j];
 s:=s/n;
 if s>max then max:=s;
 end;
writeln('max = ',max:5:1);
end.

Пример:
Результаты измерений:
   0   3   6   9  12  15  18  21
 
  -4   4   2  -4   0  -1   4   1
  -5  -2   2   3   4   0  -5  -3
  -4  -4   2   0  -3  -1  -1  -4
  -5  -3   4  -3  -4   1  -4   3
   4  -1  -5  -1  -5   2   1  -1
  -1   2   3  -1  -5   3   2   4
   1  -5  -5  -1   0   0   1   2
max =   0.9
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота