Задан двумерный целочисленный массив А из n строк и m столбцов (1 ≤ n, m ≤ 10). Составить программу, которая формирует одномерный массив В, каждый элемент которого есть произведение элементов массива А в соответствующей строке.
Пояснение: WinRar - архиватор, поддерживающий большое количество расширений архивов.
№2
ответ: Internet Explorer, MS Excel*, MS PowerPoint*.
Пояснение:
Internet Explorer - браузер от Microsoft, установленный на устройствах с Windows по умолчанию. Является системным.MS Excel (Microsoft Office Excel) - программа для работы с электронными таблицами. Входит в набор приложений Microsoft Office.MS PowerPoint (Microsoft PowerPoint) - программа для работы с презентациями. Входит в набор приложений Microsoft Office.WinZip - архиватор (если честно, про него не слышал). Не входит в набор системных программ Windows.C++ - это даже не программа, а язык программирования. Не подходит.Inkscape - редактор векторной графики. Не входит в набор системных программ Windows.
* Вообще, я не уверен насчёт того, что они прям входят в набор системных программ, так как MS Office не всегда предоставляется вместе с Windows. Но, поскольку тут нужно несколько вариантов ответа, то, думаю, это подходит больше всего.
program skype:van4es007; var s,i,d,s1,d1,j:integer; begin s:=0; s1:=0; d:=0; d1:=0; for i:=144 to 1000 do if (i mod 7 = 0) then begin s1:=s1+1; s:=s1*7 end; for j:= 144 to 1000 do If (j mod 11 = 0) then begin d1:=d1+1; d:=d1*11 end;
{sum:=d+s;
sum1:=d1+s1;
writeln('общая сумма чисел ='sum); вроде не обязательно}
writeln('общее количество чисел ='sum1); это тоже,если надо то добавь sum и sum1 }
writeln('сумма чисел кртаных 7 =',s); writeln('всего чисел кратных 7,в заданом промежутке =',s1); writeln('сумма чисел кртаных 11 =',d); writeln('всего чисел кратных 11,в заданом промежутке =',s);
ответ: WinRar.
Пояснение: WinRar - архиватор, поддерживающий большое количество расширений архивов.
№2ответ: Internet Explorer, MS Excel*, MS PowerPoint*.
Пояснение:
Internet Explorer - браузер от Microsoft, установленный на устройствах с Windows по умолчанию. Является системным.MS Excel (Microsoft Office Excel) - программа для работы с электронными таблицами. Входит в набор приложений Microsoft Office.MS PowerPoint (Microsoft PowerPoint) - программа для работы с презентациями. Входит в набор приложений Microsoft Office.WinZip - архиватор (если честно, про него не слышал). Не входит в набор системных программ Windows.C++ - это даже не программа, а язык программирования. Не подходит.Inkscape - редактор векторной графики. Не входит в набор системных программ Windows.* Вообще, я не уверен насчёт того, что они прям входят в набор системных программ, так как MS Office не всегда предоставляется вместе с Windows. Но, поскольку тут нужно несколько вариантов ответа, то, думаю, это подходит больше всего.
program skype:van4es007;
var s,i,d,s1,d1,j:integer;
begin
s:=0;
s1:=0;
d:=0;
d1:=0;
for i:=144 to 1000 do
if (i mod 7 = 0) then begin
s1:=s1+1;
s:=s1*7
end;
for j:= 144 to 1000 do
If (j mod 11 = 0) then
begin
d1:=d1+1;
d:=d1*11
end;
{sum:=d+s;
sum1:=d1+s1;
writeln('общая сумма чисел ='sum); вроде не обязательно}
writeln('общее количество чисел ='sum1); это тоже,если надо то добавь sum и sum1 }
writeln('сумма чисел кртаных 7 =',s);
writeln('всего чисел кратных 7,в заданом промежутке =',s1);
writeln('сумма чисел кртаных 11 =',d);
writeln('всего чисел кратных 11,в заданом промежутке =',s);
readln;
end.