Напишите программу, вычисляющую с использованием цикла сумму дробей от 1/ N2 до 1/(N+5) 2. Программа получает на вход число N и выводит искомую сумму. Что выведет программа при N= 5?
// PascalABC.NET 3.3, сборка 1555 от 21.10.2017 // Внимание! Если программа не работает, обновите версию!
type Ex211a=class
public
constructor(fio,phone:string); begin var n:=Max(fio.Length,phone.Length); Writeln((n+2)*'*'); Writeln('*',fio.PadRight(n),'*',NewLine,'*',phone.PadRight(n),'*'); Writeln((n+2)*'*') end; end;
type Ex211b=class
public
constructor; begin var n:=ReadInteger('Введите целое число:'); Writeln('Результат равен ',n+10) end; end;
begin new Ex211a('Иван Иванов','7-841-2666666'); new Ex211b end.
ответ:Базовая система ввода-вывода BIOS (Basic Input Output System) называется так потому, что включает в себя обширный набор программ ввода-вывода, благодаря которым операционная система и прикладные программы могут взаимодействовать с различными устройствами как самого компьютера, так и с устройствами, подключенными к нему. Вообще говоря, в архитектуре IBM-совместимого компьютера система BIOS занимает особое место. С одной стороны, ее можно рассматривать, как составную часть аппаратных средств, с другой стороны, она является как бы одним из программных модулей операционной системы.
Заметим, что система BIOS, помимо программ взаимодействия с аппаратными средствами на физическом уровне, содержит программу тестирования при включении питание компьютера POST (Power-On-Self-Test) и программу начального загрузчика. Последняя программа необходима для загрузки операционной системы с соответствующего накопителя.
// Внимание! Если программа не работает, обновите версию!
type
Ex211a=class
public
constructor(fio,phone:string);
begin
var n:=Max(fio.Length,phone.Length);
Writeln((n+2)*'*');
Writeln('*',fio.PadRight(n),'*',NewLine,'*',phone.PadRight(n),'*');
Writeln((n+2)*'*')
end;
end;
type
Ex211b=class
public
constructor;
begin
var n:=ReadInteger('Введите целое число:');
Writeln('Результат равен ',n+10)
end;
end;
begin
new Ex211a('Иван Иванов','7-841-2666666');
new Ex211b
end.
Пример
*Иван Иванов *
*7-841-2666666*
Введите целое число: 18
Результат равен 28
ответ:Базовая система ввода-вывода BIOS (Basic Input Output System) называется так потому, что включает в себя обширный набор программ ввода-вывода, благодаря которым операционная система и прикладные программы могут взаимодействовать с различными устройствами как самого компьютера, так и с устройствами, подключенными к нему. Вообще говоря, в архитектуре IBM-совместимого компьютера система BIOS занимает особое место. С одной стороны, ее можно рассматривать, как составную часть аппаратных средств, с другой стороны, она является как бы одним из программных модулей операционной системы.
Заметим, что система BIOS, помимо программ взаимодействия с аппаратными средствами на физическом уровне, содержит программу тестирования при включении питание компьютера POST (Power-On-Self-Test) и программу начального загрузчика. Последняя программа необходима для загрузки операционной системы с соответствующего накопителя.
Объяснение: