В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Фидачина
Фидачина
29.08.2021 15:44 •  Информатика

Напишите программу вычисления выражения на C++:
99 – 98 + 97 – 96 + 95 – 94 + ... + 5 – 4 + 3 – 2 + 1

Показать ответ
Ответ:
Блиллиант2812
Блиллиант2812
11.05.2021 08:50

99-98+97+96+95-94+6+5-4+3-2+1

а?

0,0(0 оценок)
Ответ:
iojhhjkl
iojhhjkl
11.05.2021 08:50

#include <iostream>

using namespace std;

signed main() {

int s = 0;

for (int i = 99; i >= 1; i--) {

 if ((i & 1) == 0)

  s -= i;

 else

  s += i;

}

cout << s;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота