В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Valentinka079
Valentinka079
01.05.2022 02:49 •  Информатика

Напишите программу (паскаль): выводится 5 строк, в которых сначала записан порядковый номер строки с точкой, а затем слово. вывести слова в алфавитном порядке. например : 1.информатика 2. 3. 4.физкультура 5. вывод: 1.информатика 5. 3. 4.физкультура 2.

Показать ответ
Ответ:
andrey5890
andrey5890
23.06.2020 17:30
Uses crt;
const n=5;
var    
s:array[1..n] of string; 
  i,j,c:integer; 
  ss:string;
begin
writeln('Введите :');
for i:=1 to n do begin 
 write('s[',i,']='); 
 readln(s[i]);                       
 end;
for i:=1 to n-1 do
for j:=i+1 to n do
if s[i]>s[j] then 
begin 
 ss:=s[i]; 
 s[i]:=s[j]; 
 s[j]:=ss; 
end;
 for i:=1 to n do
writeln(i,'.',s[i],'  ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота