В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
khadija7
khadija7
10.01.2022 01:35 •  Информатика

Напишите программу в Питоне(задачи, вторая картинка), которая получает три числа и выводит количество натуральных одинаковых чисел в этой цепочке. На примере того что снизу скинула...

Показать ответ
Ответ:
AlikhanKazbekov
AlikhanKazbekov
23.03.2020 14:50

Ирина и Тимур = не информатика 

Таня и Саша = не информатика 

Тимур = боится физики 

Таня, Тимур = не литература, но плавают 

Тимур и Таня = поздравили математика 

Ирена = cожалеет мало времени на литературу

победители по: физике, математике, информатике, литературе и географии.

Коля -  информатика (Ирена и Тимур = учит, Камилла и Эльдар = интересуются) 

Тимур - не физика, не литература, не математика, не информатика, 

значит география 

Таня - не информатика, не литература, не математика, уже не география => Физика 

Ирена - не информатика, не физика, не география => Литература 

Коля - Математика

0,0(0 оценок)
Ответ:
Артёмка12097
Артёмка12097
13.02.2020 18:57

#include <iostream>

typedef long long   ll;

using namespace std;

bool ll_is_valid(ll t, ll N, ll x, ll y)

{

return  t / x + (t - x) / y >= N;

}

ll f(ll N, ll x, ll y)

{

   ll R = 1;

   while (!ll_is_valid(R,N,x,y)) R *= 2;

ll L = R / 2;

while(R - L > 1)

{

 ll M   =   (L + R) / 2;

 

 if (!ll_is_valid(M,N,x,y)) {L = M;}

 else {R = M;}

}

return  R;

}

int  main()

{

ll N,x,y;

cin >> N >> x >> y;

if(x > y) swap( x, y );  

cout << f(N, x, y) <<  std::endl;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота