В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
arsjaja
arsjaja
07.07.2021 08:16 •  Информатика

Напишите программу, в которой у пользователя запрашивается два четырёхзначных числа A и B. Затем выведите в порядке возрастания все четырёхзначные числа в интервале от A до B, запись которых содержит ровно три одинаковые цифры.

Показать ответ
Ответ:
Karinarikfeeet
Karinarikfeeet
06.04.2021 23:51

a = input('Введите a: ')

b = input('Введите b: ')

c = 0

x = 0

a = a + b

a = list(a)

while len(a) != 0:

   if a.count(a[0]) == 3:

       if c == 0:

           c = x

       else:

           c += x

           a.remove(a[0])

   else:

       continue

print(c)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота