Напишите программу по тексту в паскале или на си+++ или на питоне пусть дана последовательность чисел a1, : , an, состоящая из 0 и 1. пару чисел (ai, aj), таких что i < j, j - i = k и ai ¹ aj, назовем неправильной. индексом неправильности последовательности (инп) назовем количество неправильных пар (ai, aj) в ней. инп легко посчитать за один проход по массиву, в котором хранятся элементы последовательности: переберем все i от 1 до n - k и сравним их с соответствующими j = i + k. если инп равен 0, то ответ в ok и никаких чисел менять в ней не нужно. иначе для каждого из элементов последовательности найдем инп после изменения этого элемента. при изменении одного числа в последовательности нулей и единиц может измениться только правильность пар (ai-k, aj) и (ai, ai+k), если они, конечно, существуют. дело в том, что i - k может быть меньше 1, или i + k - больше n. в этих случаях соответствующая пара отсутствует. значит в результате изменения одного числа, инп может измениться на -2, -1, 0, +1 или +2. если в результате изменения какого-то из чисел инп станет равным 0 - то ответ ok и номер измененного элемента, иначе - ответ fail. данный алгоритм работает за линейное относительно длины последовательности время.
2.Информатика наука о методах и процессах сбора, хранения, обработки, анализа и оценки информации, обеспечивающих возможность её использования для принятия решений.
3.Внутренние свойства — это свойства, органически присущие объекту. Они обычно «скрыты» от изучающего объект и проявляют себя косвенным образом при взаимодействии данного объекта с другими.
Внешние свойства — это свойства, характеризующие поведение объекта при взаимодействии с другими объектами.
4.Логическая информация, адекватно отображающая объективные закономерности природы, общества и мышления, получила название научнойинформации. Ее делят по областям получения или использования на следующие виды:политическая,техническая,биологическая,химическая,физическая и т.д.;по назначению - на массовую и специальную.
6. Бит, байт, килобит, мегабайт, гагабайт.
7. Система счисления, в которой значение каждого числового знака (цифры) в записи числа зависит от его позиции (разряда).
uses crt;
const n=20;
var i,cp1,cn1:integer;
p,cp,cn:real;
z:array[1..n] of integer;
begin
randomize;
for i:=1 to n do
begin
z[i]:=random(20,-20);
if z[i]>=0 then
begin
cp:=cp+z[i];
cp1:=cp1+1;
end
else
begin
cn:=cp+z[i];
cn1:=cn1+1;
end;
cp:=cp/cp1;
cn:=cn/cn1;
end;
if cp>cn then
p:=cp+cn
else
p:=cp*cn;
for i:=1 to n do
write(z[i],' ');
writeln(#13#10,cp:5:2,' ',cn:5:2,' ',p:5:2);
end.
2.
uses crt;
const n=15;m=4;
var i,j,k,flag,count:integer;
a:array[1..n,1..m] of integer;
temp:array[1..100] of integer;
b:array[1..100,1..m] of integer;
begin
randomize;
k:=1;
count:=0;
for i:=1 to n do
begin
flag:=1;
for j:=1 to m do
begin
a[i,j]:=random(51,1);
if (a[i,j]<10) or (a[i,j]>40) then
flag:=0
end;
if flag=1 then
begin
temp[k]:=i;
count:=count+1;
k:=k+1;
end;
end;
for i:=1 to count do
for j:=1 to m do
b[i,j]:=a[temp[i],j];
writeln('Массив A:');
for i:=1 to n do
begin
for j:=1 to m do
write(a[i,j],' ');
write(#13#10);
end;
if count=0 then
writeln('Нет подходящих строк.')
else
begin
writeln(#13#10,'Массив B:');
for i:=1 to count do
begin
for j:=1 to m do
write(b[i,j],' ');
write(#13#10);
end;
end;
end.