В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ElizaDevil1
ElizaDevil1
20.04.2022 08:35 •  Информатика

Написать программу на языке С (массивы)
1.Посчитать количество элементов массива, меньших 45
2.Найти среднее арифметическое элементов массива, меньших

Показать ответ
Ответ:
klemiatoeva
klemiatoeva
06.09.2020 22:21

//Братишка, я тебе опять С++ принёс

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   int n;

   cout<<"Enter size of array\n";

   cin>>n;

   int *arr = new int;

   for(int i = 0;i<n;i++){

       cin>>arr[i];

   }

   int counter_of_less_fortyfive = 0;

   vector<int>seventyeight;

   for(int i = 0;i<n;i++){

       if(arr[i]<45){

           counter_of_less_fortyfive++;

       }

       if(arr[i]<78){

           seventyeight.push_back(arr[i]);

       }

   }

   int summ_seventyeight = 0;

   for(auto &i:seventyeight){

       summ_seventyeight+=i;

   }

   float average_seventyeight = summ_seventyeight / seventyeight.size();

   cout<<"Quantity of elements wich less then 45 is "<<counter_of_less_fortyfive<<endl;

   cout<<"Average of elements wich less 78 is "<<average_seventyeight;

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота