В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Qwtyt
Qwtyt
26.03.2021 19:53 •  Информатика

Напишите программу, определяющую количество нечетных среди N введенных чисел. (Работа в


Напишите программу, определяющую количество нечетных среди N введенных чисел. (Работа в

Показать ответ
Ответ:
svetaobukhova1
svetaobukhova1
26.09.2020 13:24
Программа, которая использует два массива

var 
c, a: array[1..20] of integer; 
i: integer;
begin 
write('Первый массив '); 
for i := 1 to 20 do   begin   
c[i] := i * (-5);   
write(c[i], ' '); 
end; 
writeln; 
write('Преобразованный массив '); 
for i := 1 to 20 do   begin   
a[i] := c[20 - i + 1];   
write(a[i], ' '); 
end;  
end.

ИЛИ  Программа не использующая два массива, а просто переворачивающая первый

var 
c: array[1..20] of integer; 
i: integer;
begin  write('Первый массив '); 
for i := 1 to 20 do   begin   
c[i] := i * (-5);   
write(c[i], ' '); 
end; 
writeln; 
write('Преобразованный массив '); 
for i := 20 downto 1 do  write(c[i], ' '); 
end.

Обе программы работают!
0,0(0 оценок)
Ответ:
olgasuponeva
olgasuponeva
15.08.2021 10:04
1)
var
    s: string[6];
    n: integer;

begin
    s := 'отлично';
    n := length(s);
    writeln(length('отлично'));
    writeln(n);
end.

Изначально выставлен тип string[6], значит если присвоить строку больше, то ее обрежет по 6 символов, вот и весь прикол
ответ 6

2) рисунок

3)var
    s, s1: string;
    n: integer;

begin
    s := 'информатика';
    s1 := copy(s, 3, 5);
    n := pos(s, s1);
    writeln('s=', s);
    writeln('s1=', s1);
    writeln('n=', n);
end.

Вывод
s=информатика
s1=форма
n=0

Все верно, в s1 не содержится s, а наоборот

Садекватным объяснением! 1) дан фрагмент программы: var s: string[6]; n: integer; begin s: ='отлично
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота