В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
zangeevdima
zangeevdima
22.07.2020 12:36 •  Информатика

Напишите программу на языке паскаль «площадь треугольника с условием a+b> c, c+b> a, a+c> b» это одна программа, , , от этого зависит оценка в

Показать ответ
Ответ:
lydmilagerasim
lydmilagerasim
31.10.2022 20:31

3:

n = int(input('Введите число элементов-'))

s = 0

a = list(map(float, input().split())) #создаём список из строки, интерпретируя введённые через пробел значения как float

for i in range(n):

 if a[i] > 0: #проверяем i-й элемент массива, больше ли он нуля

   s+=1 #инкрементируем счётчик на 1

print('Сумма положительных элементов равна=',s)

4:

from random import randint #подключаем метод randint из библиотеки random

n = int(input('Введите размерность квадратной матрицы-'))

s = 0

a = [[randint(-20,20) for j in range(n)] for i in range(n)] #создаём квадратную матрицу размерностью n, элементы которой являются случайными целими числами от -20 до 20

print(a)

for i in range(n):

 for j in range(n):

   if a[i][j] < 0: #проверяем элемент на знак

     s+=1 #инкрементируем счётчик

print('Количество отрицательных элементов-',s)


Первые два сделала а эти не могу (
0,0(0 оценок)
Ответ:
Violet17
Violet17
22.09.2020 15:58

Объяснение:

1. Вид рабочего стола зависит от пользователя, его настроек. В нашем классе настройка рабочего стола для пользователя «student», как и работа на нём, для однообразия закрыта. На рабочем столе выделяют рабочее поле 1 рабочего стола, и серую специальную полосу 2- панель задач. На рабочем поле находятся специальные графические изображения  физических и логических объектов – пиктограммы. Пиктограммы могут обозначать физический объект, реально существующий, например, пиктограмма «Мой компьютер» 3, или логический объект, например, пиктограмма папки 4 (на самом деле никакой папки в компьютере нет, это именованная часть жёсткого диска). Среди пиктограмм особое место занимают ярлыки 5 – специальные пиктограммы, которые содержат указания операционной системе по поиску тех объектов, для которых они созданы (они могут быть созданы для любого объекта – программы, папки, документа, диска и т.п.).  

На панели задач (2) находятся кнопки тех программ, документов, объектов, которые активизированы и работают в данное время (Windows – многозадачная операционная система). Отсюда и само название элемента. В данном случае кнопка 6 “SYSTEM (C)” отжата, окно системного диска свёрнуто в кнопку, а чтобы его развернуть, надо ещё раз щёлкнуть по кнопке. Кроме этого на панели задач слева находится одна из основных кнопок Windows – кнопка «Пуск» 7, которая позволяет вызвать основное меню Windows. Справа на панели задач находится индикатор раскладки клавиатуры 8 (переключение в нашем классе производится нажатием клавиш Ctrl+Shift). В правом углу панели находится индикатор системных часов 9. Остальные пиктограммы панели задач зависят от настроек операционной системы Windows пользователем.

2. Для работы с программами и устройствами компьютера используются различные графические элементы управления, например командные кнопки. Так, во время работы компьютера в левом нижнем углу экрана находится кнопка Пуск, о которой мы говорили на уроке. Нарисованную на экране обычного компьютера кнопку бессмысленно нажимать пальцем (как это можно делать на большинстве планшетов и смартфонов), но на нее можно воздействовать с мыши. Как правило, у мыши две кнопки: левая и правая. Указательный палец располагается на левой кнопке, потому что она является основной. Когда с мышью работает левша, функции правой и левой кнопок можно поменять.

3. Диалоговое окно в графическом пользовательском интерфейсе — специальный элемент интерфейса, окно, предназначенное для вывода информации и (или) получения ответа от пользователя. Получил своё название потому, что осуществляет двустороннее взаимодействие компьютер-пользователь («диалог»): сообщая пользователю что-то и ожидая от него ответа.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота