В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Maks2801
Maks2801
19.01.2022 03:26 •  Информатика

Напишите программу на python, которая вычисляет остаток от двух целых чисел путем их деления

Показать ответ
Ответ:
нуралик
нуралик
14.09.2022 17:00
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
  var a:=MatrixRandom(7,7,0,9);
  var k:=0;
  for var i:=0 to 6 do begin
    for var j:=0 to 6 do begin
      Write(a[i,j]:3);
      if a[i,j] in [1..5] then Inc(k)
      end;
    Writeln
    end;
  Writeln('Кол-во элементов на [1,5]: ',k)
end.

Тестовое решение:
  2  1  7  3  3  2  7
  9  2  9  2  0  5  5
  4  2  6  9  4  6  0
  1  0  3  5  4  5  9
  6  3  6  0  2  0  8
  0  8  4  3  2  1  8
  6  0  4  4  5  4  0
Кол-во элементов на [1,5]: 27

Вариант "совсем для школы"

const
  n=7;
var
  a:array[1..n,1..n] of integer;
  i,j,k:integer;
begin
  Randomize;
  k:=0;
  for i:=1 to n do begin
    for j:=1 to n do begin
      a[i,j]:=Random(10);
      Write(a[i,j]:3);
      if a[i,j] in [1..5] then Inc(k)
      end;
    Writeln
    end;
  Writeln('Кол-во элементов на [1,5]: ',k)
end.
0,0(0 оценок)
Ответ:
07Лизочек07
07Лизочек07
31.12.2020 00:01
1. С=2*Pi*R, S= Pi*R^2, V=4/3*Pi*R^3, где Pi=3,14, заданный радиус R
2. P=a+b, S=1/2*a*b, где a и b - данные катеты
3. Пусть даны координаты трех вершин треугольника A(x1;y1), B(x2;y2), C(x3;y3).
Расстояние между двумя точками вычисляется по формуле
d= \sqrt{ ( x_{2} - x_{1} )^{2}+ ( y_{2} - y_{1} )^{2} }
Тогда периметр треугольника можно вычислить по формуле:
P=sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2).
Площадь треугольника по формуле Герона вычисляется по формуле:
s= \sqrt{p(p-a)(p-b)(p-c)}, где p= \frac{a+b+c}{2}-полу периметр треугольника.
S=sqrt((sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2*(sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2-sqrt((x2-x1)^2+(y2-y1)^2))*(sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2-+sqrt((x3-x2)^2+(y3-y2)^2))*(sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2-sqrt((x3-x1)^2+(y3-y1)^2))
4. Среднее геометрическое трех чисел вычисляется по формуле
\sqrt[3]{abc} или
(a*b*c)^1/3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота