1. Составьте программу, которая выводит элементы кратные 5 в одномерном массиве ве Z[13].
2. Составьте программу, которая выводит положительные элементы в одномерном массиве
иве W[18].
3. Составьте программу, которая заменяет элементы кратные 3 в массиве Т[9] формируемых из
(-15; 25) на 0.
1
4. Составьте программу, которая подсчитывает количество элементов больших 1 в массиве D[7].
диапазона
#include <iostream>
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
int n, a, b, c, d, e, f, k=0;
cin >> n;
a=n%10;
b=n%100/10;
c=n%1000/100;
d=n/1000;
e=n-d*1000-b*10+d*10+b*1000;
cout<<e<<endl;
if (a%2==0)++k; if (b%2==0)++k; if (c%2==0)++k; if (d%2==0)++k;
f=a; if (b<f) f=b; if (c<f) f=c; if (d<f) f=d;
if (b>a) a=b; if (c>a) a=c; if (d>a) a=d;
cout<<"Наименьшая цифра числа "<<f<<endl<<"Наибольшая цифра числа "<<a<<endl;
if (n%2==0)cout<<"Число делится на 2"<<endl;
else cout<<"Число не делится на 2"<<endl;
if (n%7==0)cout<<"Число делится на 7"<<endl;
else cout<<"Число не делится на 7"<<endl;
if (n%123==0)cout<<"Число делится на 123"<<endl;
else cout<<"Число не делится на 123"<<endl;
cout<<"Число четных цифр в числе равно "<<k<<endl;
return 0;
}
#include <iostream>
using std::cout;
using std::endl;
#include <cstdlib>
using std::rand;
using std::srand;
#include <ctime>
using std::time;
int main()
{
int a[10];
srand(time(0));
for(int i = 0; i < 10; i++)
{
a[i] = rand() % 201 - 100;
cout << a[i] << ' ';
}
cout << endl;
int temp;
for(int i = 0; i < 5; i++)
{
temp = a[i];
a[i] = a[i + 5];
a[i + 5] = temp;
}
for(int i = 0; i < 10; i++)
{
cout << a[i] << ' ';
}
cout << endl;
return 0;
}