Напишите программу на c++.Условие:
Напишите программу, которая переставляет соседние элементы массива: 1-й со 2-м, 3-й с 4-м и т.д. Нумерация элементов начинается с единицы. Если в массиве нечётное количество элементов, последний элемент остаётся на своём месте.
Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .
Выходные данные
Программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами.
Const
s=5;
Var
ar:array[1..s] of integer;
n,m,i:integer;
begin
writeln('N');
readln(n);
writeln('M');
readln(m);
writeln('Array:');
for i:=1 to s do
readln(ar[i]);
writeln('First array:');
for i:=1 to s do
begin
write(ar[i]:4);
if ar[i] div n<>0 then ar[i]:=ar[i]+m;
end;
writeln;
writeln('Final array:');
for i:=1 to s do
write(ar[i]:4);
end.
Пример ввода:
3
3
1
2
3
4
5
Пример вывода:
First array:
1 2 3 4 5
Final array:
1 2 6 7 8
//Блок-схема во вложении
Айнымалы —
әріп түрінде немесе әріптер тобы түрінде программаға енгізілетін және уақыт, ұзындық, баға, түс және т.б. әр түрлі мәндерді қабылдайтын программадагы сандық шама;
белгілі бір мәліметтер типін сақтай алатын және программаны атқару барысында мәнін өзгертуге болатын атауы белгілі объект.
[1]
Айнымалылар әдетте кіші латын немесе грек әріптерімен (индекстерімен болуы мүмкінами) белгіленеді: {\displaystyle x,~y,~\varepsilon }{\displaystyle x,~y,~\varepsilon }.
Өзгеру облысы айнымалылардың сәйкес әріптермен, бірақ ирек жақшамен алынып белгіленеді: {\displaystyle \left\{x\right\},~\left\{y\right\},~\left\{\varepsilon \right\}}{\displaystyle \left\{x\right\},~\left\{y\right\},~\left\{\varepsilon \right\}}.
Айнымалы және тұрақты шама
А й н ы м а л ы шама — әр түрлі сан мәндерін қабылдайтын шама. Ал сан мәні өзгеріссіз қалатын шама т ұ р а қ т ы шама деп аталады. Дегенмен айнымалы шама мен тұрақты шаманың арасындағы айырмашылық салыстырмалы түрде болады. Өйткені кейбір мәселедегі тұрақты шама, басқа бір жағдайда айнымалы шама болуы мүмкін.
Айнымалы шаманы математикаға енгізіп, оны жүйелі түрде зерттеуді бастаған француз ғалымы Рене Декарт (1596 — 1650) болды. Айнымалы шаманың негізінде өзгеріс пен қозғалыс жатыр. Сондықтан тұрақты шама математикасынан айнымалы шама математикасына көшу ғылыми ойлаудағы үлкен төңкеріс болды. Сөйтіп, интегралдық және дифференциалдық есептеу әдістері арқылы процестер мен өзгерістерді зерттеуге мүмкіндік жасалды. Кейде айнымалы шамалар арасындағы байланысты функция деп те атайды. Математика онан әрі дамыған сайын зерттелетін функциялар саны да көбеюде.[2]
Тәуелсіз және тәуелді
Зерттелетін мәселелерде бірден артық айнымалылар болса тәуелсіз және тәуелді айнымалыларға ажыратылады.Тәуелді айнымалылар тәуелсіз айнымалылардың(аргументтердің) функциясы ретінде қарастырылады.Жоғарыда мысалға келтірілген қозғалыста, егер h биіктіктің t уақытқа тәуелділігі зерттелетін болса, онда тәуелсіз айнымалы - t уақыт болып есептеледі, ал тәуелді айнымалы t-ның функциясы - h биіктік болады; егер жылдамдықтың биіктікке тәуелділігі зерттелетін болса, онда биіктік тәуелсіз айнымалы, ал жылдамдық h-тың функциясы болады.Сонымен, айнымалы тек бір-біріне ғана қатысты тәуелді немесе тәуелсіз болады, бұлардың айырмашылығы есептің
Объяснение:
вот