В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
олькаlove1
олькаlove1
28.01.2021 18:59 •  Информатика

Напишите программу, которая запрашивает фамилии студентов и их почтовые адреса, записывает полученные данные в файл "номер_группы.txt" и
выводит список из файла на экран (Решение этой задачи может быть разным:
самое простое - организовать ввод и запись данных по одной строке, более
сложный вариант - организовать цикл из нескольких итераций, их количество
можно уточнять у пользователя: "Сколько строк данных Вы хотите ввести?"
или спрашивать после ввода одной строки: "Ввести еще данные?" и т.п. Здесь
можно решить любым , который Вам понятен на данном этапе
изучения языка).
сделать в питоне

Показать ответ
Ответ:
Var k, s, i: integer;beginreadln(k);s:=k mod 10;i:=0;while k<>0 do begin
k:=k div 10;
if s<k mod 10 then begins:=k mod 10;i:=0;end;if s=k mod 10 theni:=i+1;end;writeln(i);end.
В переменной k вводим число, в переменной s храним максимальную цифру, в переменной i подсчитываем вхождение максимальной цифры в число

var k, s, i: integer;beginreadln(k);//вводим числоs:=k mod 10;//предполагаем что последняя цифра - максимальнаяi:=0;// инициализируем счетчик нулемwhile k<>0 do begin//цикл идет до тех пор пока не закончатся цифры в k
k:=k div 10;// отбрасываем цифру от числа
if s<k mod 10 then //если s < последней цифры kbegins:=k mod 10;//то меняем нашу максимальную цифру на новуюi:=0;// и сбрасываем счетчикend;if s=k mod 10 then// если цифра в числе равна максимальной цифреi:=i+1;//прибавляем 1 к счетчикend;writeln(i);//выводим количество вхождений максимальной цифры end.
0,0(0 оценок)
Ответ:
Никита20220
Никита20220
08.08.2020 15:38
"Память ЭВМ служит для хранения исходных данных, команд программ, а также промежуточных и окончательных результатов вычислений. Информация, содержащаяся в памяти компьютера, по мере необходимости выдаётся в другие устройства машины (Центральное устройство управления, Арифметико-логическое устройство, устройства вывода и др.) .
Основная память тесно связана с Арифметико-логическим устройством и служит для хранения информации, используемой в ближайшей серии вычислений.
Информация из основной памяти обычно извлекается определёнными порциями.
Все ячейки основной памяти пронумерованы.
Номера ячеек памяти являются адресами тех данных, которые хранятся в них.
При считывании машинного слова из ячейки основной памяти содержимое этой ячейки при необходимости восстанавливается и может быть в дальнейшем снова получена из той же ячейки.
При записи информации хранившиеся в ячейке памяти слово стирается и его место занимает
Наряду с оперативной и сверхоперативной памятью в современных компьютерах используется ещё один вид внутренней памяти – постоянная память, реализуемая постоянными запоминающими
Постоянные запоминающие устройства служат для хранения различных констант и постоянных программ. Информация в них записывается однократно, обычно в процессе изготовления устройства, а в дальнейшем только считывается без разрушения.
В тех случаях, когда занесение информации производится в эксплуатационных условиях соответствующей настройкой, такие постоянные запоминающие устройства называются программируемые постоянные запоминающие
Внутренняя память ЭВМ (основная память, сверхоперативная память, постоянные запоминающие устройства, программируемые постоянные запоминающие устройства) непосредственно взаимодействуют с процессором и вместе с ним образуют центральную часть (ядро) компьютера. Кроме центральной части в состав компьютера входят также различные периферийные ( внешние) устройства, которые по своему значению делятся на две внешней памяти, предназначенные для хранения больших массивов ввода и вывода, обеспечивающие связь компьютера с внешней средой, в том числе с пользователями, путём ввода в компьютер информации, её регистрации и
информацией между центральной частью и периферийными устройствами ЭВМ ..."
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота