В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
samayazeynalova02
samayazeynalova02
08.05.2022 21:45 •  Информатика

Напишите программу, которая заполняет массив из n элементов в обратном порядке последовательными натуральными числами, начиная с последнего элемента, который должен быть равен x . входные данные входная строка содержит два целых числа: начальное значение x и размер массива n , разделённые пробелом. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести содержимое массива: убывающую последовательность из n последовательных натуральных чисел; последний элемент должен быть равен x . программа - python ! только python

Показать ответ
Ответ:
katyaarbato
katyaarbato
13.08.2020 21:21
Если правильно понял условие, то может быть так:

x,n = map(int,(input('input x,n ').split()))
a=[0]*n
print('input')
for i in range(n):
    a[i]= x-i
    print(a[i])
print('Output')
for i in range(n):
    print(a[i]+n-1)

Тестовое решение:
input x,n 10 5
input
10
9
8
7
6
Output
14
13
12
11
10
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота