К рисунку - Елочка написать программу с использованием цикла и вс алгоритма . В результате работы программы на координатной плоскости должно отобразиться две елки маленькая и большая, с повторением 3 раза
Все настройки свойств в битрикс можно выполнять из визуальной части сайта, для этого нам нужно перейти именно в тот раздел или страницу, с которой на данный момент собираемся работать. Переходим в нужный нам раздел, в административном меню нажимаем «Изменить страницу», из выпадающего списка выбираем «Заголовок и свойства страницы».
Выбор свойств в административном меню
Нам появилась форма для заполнения, давайте более детальней разберем ее поля:
Заголовок – заголовок самой страницы, он же может быть title если не заполнено свойство «Заголовок окна браузера», а также подставляется как h1, которое видите на страничке;
Описание страницы – это описание самой страницы description то самое описание, которое поисковики могут взять как краткое содержание текста на странице;
Ключевые слова – keywords, перечисляем тут ключевые словосочетания.
Заголовок окна браузера – он же title, если поле не заполнено, то значение в title подставляется из поля «Заголовок»;
Продвигаемые слова – тут можно прописать слова, по которым планируете продвигать страницу, далее эти слова можете использовать в свое усмотрение, играясь с логикой и функционалом самого сайта.
ROBOTS – в данное поле прописываем служебную информацию да роботов поисковых систем;
Теги – в данном поле прописываем слова для использования по ним поиск данной страницы, так же учитывайте, что поиск дополнительно нужно настроить, что бы он корректно работал.
1) Program Massiv1;
Uses Crt;
var k:array[1..12] of real;
i,c:integer;
begin
clrscr;
write('Введите элементы массива k:');
c:=0;
for i:=1 to 12 do
begin
readln(k[i]);
if (k[i]<0) then Inc(c);
end;
writeln;
writeln;
for i:=1 to 12 do write(k[i]:4:4);
writeln;
writeln('Количество элементов <0:',c);
readkey;
end.
2) Program Massiv2;
Uses Crt;
var m:array[1..10] of integer;
i,c:integer;
begin
clrscr;
write('Введите элементы массива m:');
c:=0;
for i:=1 to 10 do
begin
readln(m[i]);
if (m[i]=3) then Inc(c);
end;
writeln;
writeln;
for i:=1 to 12 do write(m[i]:4);
writeln;
writeln('Количество элементов =3:',c);
readkey;
end.
В третьем задании видимо имеется ввиду номер элемента этого массива, т.к по условию задачи массив у нас один.
3) Program Massiv3;
Uses Crt;
var m:array[1..8] of integer;
i,c,max:integer;
begin
clrscr;
write('Введите элементы массива m:');
c:=0;
for i:=1 to 8 do readln(m[i]);
writeln;
writeln;
max:=m[1]
for i:=1 to 8 do
begin
if (m[i]>max) then
begin
max:=m[i];
c:=i
end;
write(m[i]:4);
end;
writeln('Индекс максимального элемента =:',c);
readkey;
end.
4) Program Massiv4;
Uses Crt;
var m:array[1..12] of integer;
i,c,max,sum:integer;
begin
clrscr;
write('Введите элементы массива m:');
c:=0; sum:=0;
for i:=1 to 12 do readln(m[i]);
writeln;
writeln;
max:=m[1]
for i:=1 to 12 do
begin
if (m[i]>max) then
begin
max:=m[i];
c:=i
end;
write(m[i]:4);
end;
for i:=1 to c-1 do sum:=sum+m[i];
writeln('Количество элементов расположенных до max :',с-1);
writeln('Сумма элементов расположенных до max :',sum);
readkey;
end.
В пятом задании видимо имеется ввиду значения элементов массива меньшие чем сумма первого и последнего
5) Program Massiv5;
Uses Crt;
var k:array[1..15] of real;
sum:real;
i,c:integer;
begin
clrscr;
write('Введите элементы массива k:');
c:=0;
for i:=1 to 15 do readln(k[i]);
sum:=k[1]+k[15];
writeln;
writeln;
for i:=1 to 15 do
begin
write(k[i]:4:4);
if (k[i]<sum) tnen Inc(c);
end;
writeln;
writeln('Количество элементов :',c);
readkey;
end.
Все настройки свойств в битрикс можно выполнять из визуальной части сайта, для этого нам нужно перейти именно в тот раздел или страницу, с которой на данный момент собираемся работать. Переходим в нужный нам раздел, в административном меню нажимаем «Изменить страницу», из выпадающего списка выбираем «Заголовок и свойства страницы».
Выбор свойств в административном меню
Нам появилась форма для заполнения, давайте более детальней разберем ее поля:
Заголовок – заголовок самой страницы, он же может быть title если не заполнено свойство «Заголовок окна браузера», а также подставляется как h1, которое видите на страничке;
Описание страницы – это описание самой страницы description то самое описание, которое поисковики могут взять как краткое содержание текста на странице;
Ключевые слова – keywords, перечисляем тут ключевые словосочетания.
Заголовок окна браузера – он же title, если поле не заполнено, то значение в title подставляется из поля «Заголовок»;
Продвигаемые слова – тут можно прописать слова, по которым планируете продвигать страницу, далее эти слова можете использовать в свое усмотрение, играясь с логикой и функционалом самого сайта.
ROBOTS – в данное поле прописываем служебную информацию да роботов поисковых систем;
Теги – в данном поле прописываем слова для использования по ним поиск данной страницы, так же учитывайте, что поиск дополнительно нужно настроить, что бы он корректно работал.
Объяснение: