В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Antyan11
Antyan11
17.02.2021 19:46 •  Информатика

Напишите программу, которая вычисляет значение следующей функции:
y = {█ (x-15, если x> 0 @ 7, если x = 0 @ x ^ 2, если x <0) ┤

Показать ответ
Ответ:
AidarSharafutdinov
AidarSharafutdinov
07.01.2021 23:43
Дешифровка: ВХОД_ОТКР Ы Т.

дешифровки:
Const sh = '_.,';
Var
  St : String;
  i  : Integer;
Function DeCode(S : String; Tabl : String; k : Integer) : String;
Var j,n : Integer;
Begin
  For j:=1 to Length(S) do
  Begin
    n:=Pos(S[j],sh);
    If n>0 then
    Begin
      n:=n+k;
      While n>Length(sh) do n:=n-Length(sh);
      While n<=0 do n:=n+Length(sh);
      S[j]:=sh[n];
    end
  end;
  DeCode:=S;
end;
Begin
  St:='ЗЫФЙГФШРЦ . ШД';
  Writeln(Decode(St,sh,-6));
  //For i:=-10 to 10 do Writeln(Decode(St,sh,i));
end.
0,0(0 оценок)
Ответ:
Onewood
Onewood
22.08.2021 09:05

{данная программа переводит любое сочетание символов ascii в систему счисления заданную пользователем.}

//pascal abc.net v3.0 сборка 1111

var

  a,i,b,r,n,j,bug: integer;

  s,se,slo,slof: string;

procedure preob(var a,b,n: integer; var se: string);

  begin

  repeat

    b: =a mod n;

    a: =a div n;

    str(b,se);

    s+=se;

  until (a< =n-1);

  end;

beginreadln(slo);

readln(n);

for j: =1 to length(slo) do

begin;

a: =ord(slo[j]);

preob(a,b,n,se);

str(a,se);

s+=se;

for i: =1 to length(s) div 2 do

begin;

se: =s[i];

s[i]: =s[length(s)-i+1];

s[length(s)-i+1]: =se[1];

end;

write(s,'-');

slof: =slof+s;

delete(s,1,length(s));

end;

end.

пример ввода:

работа на завтра.

2

пример вывода:

11000100-11101110-11101100-11100000-11111000-11101101-11111111-11111111-100000-11110000-11100000-11100001-11101110-11110010-11100000-100000-11101101-11100000-100000-11100111-11100000-11100010-11110010-11110000-11100000-101110-

{таким образом, фразу " работа на завтра." можно закодировать как "11000100-11101110-11101100-11100000-11111000-11101101-11111111-11111111-100000-11110000-11100000-11100001-11101110-11110010-11100000-100000-11101101-11100000-100000-11100111-11100000-11100010-11110010-11110000-11100000-101110-".}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота