В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ник3999
ник3999
22.12.2021 13:36 •  Информатика

Напишите программу, которая создаёт и выводит массив из действительных чисел случайным размером от 4 до 10 строк и столбцов, затем через пустую строку выводит тот же массив, но выводит его столбец так, чтобы поменялся местами с последним.

Показать ответ
Ответ:
nadezhda980
nadezhda980
09.10.2020 12:28
PascalABC.NET 3.4.2, сборка 1884 от 24.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var (m, n) := (Random(4, 10), Random(4, 10));

 Writeln('*** Исходный массив ***');

 var a := MatrRandomReal(m, n, -99, 99);

 a.Println(8, 3);

 Writeln('*** Полученный массив ***');

 a.SwapCols(1, a.ColCount - 1);

 a.Println(8, 3)

end.


Напишите программу, которая создаёт и выводит массив из действительных чисел случайным размером от 4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота