В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Sh4urma
Sh4urma
07.11.2020 03:12 •  Информатика

Напишите программу которая принимает с клавиатуры целое число часов и выводит на экран! ​

Показать ответ
Ответ:
Emil304
Emil304
23.03.2019 11:50

type cl = class

  a: integer;

  constructor create(b: integer);

  procedure setval(b: integer);

  function getval: integer;

  procedure sq;

end;

constructor cl.create(b: integer);

begin

  a : = b;

end;

procedure cl.setval(b: integer);

begin

  a : = b;

end;

function cl.getval: integer;

begin

  getval : = a;

end;

procedure cl.sq;

begin

  if a < 0 then

    writeln('a ^ 2 = ', a * a)

  else

    writeln('error');

end;

var

  obj: cl;

  a : integer;

begin

  write('a = ');

  readln(a);

  obj : = cl.create(a);

  obj.sq;

  readln;

  obj.destroy;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота