В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Vitalihka
Vitalihka
05.10.2020 05:30 •  Информатика

Напишите программу, которая получает случайное натуральное число из отрезка [64; 511] и выводит на экран запись этого числа в восьмеричной системе счисления. Оформите вывод так, как в примере: Случайное число 83

В восьмеричной системе 123
Язык python

Показать ответ
Ответ:
AlexBennet
AlexBennet
18.11.2020 09:41

import random

def to8(x):

       new=''

       while x>0:

           new=str(x%8)+new

           x //= 8

       return(new)

a=random.randint(64,511)

print('Случайное число',a)

print('В восьмеричной системе',to8(a))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота