В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Кабасена05
Кабасена05
23.05.2022 12:05 •  Информатика

Напишите программу, которая по двум данным натуральным числам a и b, не превосходящим 30000, подсчитывает количество натуральных чисел, кратных 10, на отрезке [a,b] . Программа получает на вход два натуральных числа a и b, при этом гарантируется, что 1 < a < b < 30 000. Проверять входные данные на корректность не нужно. Программа должна вывести одно число: количество натуральных чисел, кратных 10, на отрезке [a,b].

Пример работы программы:

Входные данные: 7, 37

Выходные данные: 3

Показать ответ
Ответ:
илья20032101
илья20032101
14.10.2020 13:28

a = 7

b = 37

count = 0

while a != b:

  if a % 10 == 0:

       count += 1

       

   a += 1

print(count)

Объяснение:

0,0(0 оценок)
Ответ:
Lopkrtjvbbcx
Lopkrtjvbbcx
14.10.2020 13:28
ответ:

var a, b: smallint;

begin

   readln(a, b);

   writeln(b div 10 - a div 10);

end.

Ну или если надо с циклом и лишней переменной, а хитро и подло сделать нельзя:

var a, b, c: smallint;

begin

   readln(a, b);

   for var i := a to b do

       if (i mod 10 = 0) then c += 1;

   writeln(c);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота