В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
karenkar108
karenkar108
18.08.2020 05:29 •  Информатика

Составить программу ! вот условие: разработать схему алгоритма, который вводит массив из n целых чисел и выводит на экран этот же массив в прямом и обратном порядке. протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. на паскале

Показать ответ
Ответ:
sofyaderka4eva
sofyaderka4eva
22.07.2020 23:55
Var n,i:integer;
a:array[1..1024] of integer;
begin
randomize;

write('N=');
readln(n);

for i:=1 to n do
a[i]:=random(2*n+1)-n;

write('V pramom poradke - ');
for i:=1 to n do
write(a[i],' ');
writeln;

write('V obratnom poradke - ');
for i:=n downto 1 do
write(a[i],' ');
writeln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота