В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
faystt
faystt
11.08.2022 16:31 •  Информатика

Напишите программу, которая оценит справедливость конспирологического тарифа. Из списка чисел нужно выбрать те, что имеют ту же чётность, что и минимальное.

Формат ввода
Вводится строка целых чисел, записанных через пробел.

Формат вывода
Вывести числа, которые имеют ту же чётность, что и наименьшее, без повторений, порядок вывода неважен.

Пример 1
Ввод
2 5 17 3 18 6 1 9
Вывод
1 3 5 9 17

Показать ответ
Ответ:
nikusachev01
nikusachev01
11.01.2021 07:19

a = list(map(int, input().split()))

m = min(a)

res = []

for i in range(len(a)):

   if(a[i]%2==m%2 and a[i] not in res):

       res.append(a[i])

for row in range(len(res)):

   print(res[row], end=' ')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота