В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
homka16072006
homka16072006
01.05.2022 22:40 •  Информатика

Напишите программу, которая находит сумму элементов массива (25 целых чисел, которые вводятся с клавиатуры), и выводит на экран среднее значение его элементов. программа: pascal abc.

Показать ответ
Ответ:
ManemiDragnil
ManemiDragnil
17.09.2020 23:27
Const
  n = 25;
var
  a: array[1..n] of integer;
  i, s: integer;
begin
  Writeln('Введите элементы массива');
  s := 0;
  for i := 1 to n do
  begin Read(a[i]); s := s + a[i] end;
  Writeln('Среднее значение элементов массива равно ', s/n)
end.
0,0(0 оценок)
Ответ:
iMpreSS1ve1337
iMpreSS1ve1337
17.09.2020 23:27
Var A:array[1..25] of Integer;
i:integer;
S:real;
begin
Readln(N);
For i:=1 to 25 do
Readln(A[i]);
For i:=1 to 25 do
S:=S+A[i];
S:=S/25;
Writeln(S);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота