В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
PolinaКэт
PolinaКэт
11.01.2021 20:25 •  Информатика

Напишите программу для вычисления формулы z = (x·y) / (x + y). Все числа 16-битные целые со знаком. Ассемблер!

Показать ответ
Ответ:
kostyasmirnov
kostyasmirnov
22.06.2021 15:12
Program pr;
uses crt; 
Var a,b,c:integer; 

Begin   
Write('Введите 1-ю сторону: '); Readln(a);   
Write('Введите 2-ю сторону: '); Readln(b);   
Write('Введите 3-ю сторону: '); Readln(c); 
  
{Проверка на существование треугольника} 
if ((a+b)>c) and ((a+c)>b) and ((b+c)>a)   then        
     Begin                     
          if ((a=b)or (b=c) or (a=c)) then               
                Writeln('Треугольник равнобедренный');                       
 
         if ((a=b) and (b=c)) then               
            Writeln('Треугольник равносторонний')                 
         else Writeln('Треугольник разносторонний');           
  
        if ((a*a+b*b = c*c) or (a*a+c*c = b*b) or (b*b+c*c = a*a))    then
             Writeln('Треугольник прямоугольный');                      
    end   
   else       Writeln('Треугольник нельзя построить');    

Readln(); 
END.
0,0(0 оценок)
Ответ:
Рита460
Рита460
30.08.2021 17:16
1. Не знаю. Вопрос точно правильно написан?
2. в.пиксель
3. а.красный, синий, зеленый
4. а.хранения информации о цвете каждого пикселя экрана монитора
5. г.программа для создания и редактирования рисунков
6. б.графических примитивов
7.б. растровой графики
8. а.электронное устройство для хранения двоичного кода изображения, выводимого на экран
9.  а.дисплейный процессор и видеопамять(немного есть сомнения)
10. в. bmp
11.Разрешающая сканера 300 dpi (dot per inch - точек на дюйм) означает, что на отрезке длиной 1 дюйм сканер различить 300 точек.
Переведем разрешающую сканера из точек на дюйм (1 дюйм = 2,54 см) в точки на сантиметр:
300dpi : 2,54 ≈ 118 точек/см.
Следовательно, размер изображения в точках составит
25*118 и 30*118 = 2950х3540
Общее количество точек изображения равно:
2950 * 3540 = 10 443 000.
Информационный объем файла равен:
3 байта= 24 бита. 24 * 10 443 000 = 250632000 бит = 31329000 байт = 30595 Кб ≈ 30 Мб
12.65536 означает, что на каждый пиксель отводится два байта. Итого имеем 1280*2КБ=2,5МБ.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота